Hot answers tagged

8

There is a lot of very useful information from Microsoft but SharePoint Alerts are counter-intuitive on a lot of levels. The number one rule when dealing with them is to never assume that they follow a predictable pattern because they do not and will surprise you every time. They also love to work perfectly for 100 days straight, then for no discernible ...


6

Couple of things to check: Make sure "Microsoft SharePoint Foundation Incoming E-Mail" timer job is running on the server where SMTP confgiured. From Central admin, Incoming email setting > advance setting, make sure drop folder path added here. Make sure Timer Services having the correct permission on drop folder.


6

For debug purposes, you can do a few things. First is to use the Send-MailMessage cmdlet. This is an alternative to using telnet to test SMTP functionality. If neither of these work, I would take a look at the SMTP server logs. Those logs may show that the SMTP server is dropping the mail due to access permissions (perhaps scoped IP range on a receive ...


5

I had same problem, after all I changed in Configure Incoming E-Mail Settings->Settings mode to -> ADVANCED and specified E-mail drop folder Path :c:\inetpub\mailroot\drop. I hope this answer will help somebody :) .


5

On a multi-server farm, be sure the "Microsoft SharePoint Foundation Incoming E-Mail" service is running on the same server you're using for the SMTP service, presumably one of your front end servers. Check this in Central Admin-System Settings-Manage Services on Server and cycle through your servers on the top-right. In my case the above mentioned service ...


3

The outbound SMTP server should be the domain that the SMTP server is whenever you open the IIS 6.0 Manager -> SMTP Server -> Domains -> Domain Name. In the picture below, the SMTP server would be zjsptest.zjsptest.com


3

You can't use the System.Net.Mail namespace or SPUtility.SendEmail with Office 365/Sandbox solutions. SPSE - Send email via code in Office365


3

If nothing above has helped, then I would check whether your application pool and timer service accounts have permissions to the drop folder. Probably they don't. Some time ago it was the cause of the issue in my case. To configure this permissions do the following: Verify that you have the following administrative credentials: You must be a member of the ...


3

You must configure your Exchange server (or any email server you use to send emails in your organization) to route emails @OurSharePointServerName-OurDomainName to the IP address of the SharePoint server where the SMTP service is enabled. See "Step2: Create Send and Receive Connectors in Exchange 2010" at http://blogs.msdn.com/b/pareshg/archive/2010/04/23/...


2

If you have more than one APP Server, check whether the drop folder is on the same server where the timer is running, else you have to share the folder and add the path in Central Admin. Reference : http://bernado-nguyen-hoan.com/2013/06/18/solving-sharepoint-2013-incoming-mails-stuck-in-drop-folder/


2

I came across the same issue on SharePoint 2013. As strange as it sounds, but solution was to change the value of Sandboxed Solutions resource Quota from 0 to something else.


2

There is a bug where, under certain conditions (usually related to 2007-2010 upgrade or when a server name changes) a list will become 'stuck' where it cannot receive email. The fix is fortunately extremely simple and painless : Go to the list properties and select 'Incoming Email Settings' Copy the current email address to someplace else, like Notepad++ ...


2

This seems kinda "dirty" but it works. http://www.delphi-ts.com/blogs/lozzi/post/2011/02/09/Sending-SharePoint-emails-through-alternate-ports.aspx Basically setting up a proxy for sending mail, pointing SharePoint to the proxy (standard port), and allowing the proxy to relay to the correct destination port.


2

You need to have SMTP server installed on the dev box so that it can receive email from the Lotus Notes box. Also, Lotus Notes box needs to know where to send the mail. So if you have developer@mydevbox.com as the recipient URL, that mydevbox.com needs to resolve to your dev box. I haven't tried this myself, but you might be able to just use HOSTS file on ...


2

SharePoint WFE are responsible to send the emails to user. I think you are talking about the relay setting. You should enter the WFE Ips their. IP addresses of Web Front End’s in you farm. But if you want to use all servers in the farm then select all except the list below option.


2

Most probably the problem does not come from the SharePoint configuration, but from the SMTP relay you use. Do you use IIS 6.0 as the local SMTP? Does it then forward the email to an Exchange server or else? The local SMTP relay or the Exchange server configurations have to be investigated first.


2

You might have to allow the WFE to relay emails through Exchange as well. Some emails are actually sent by timer jobs in SharePoint, for example there is a timer job called "Immediate Alerts" which sends email to users who have registered for alerts on lists/libraries. Depending on configurations made SharePoint could pick any of your servers to run timer ...


2

Try this method: Without attachment using SPUtility. private Boolean SendEmail() { try { bool flag = false; SPSecurity.RunWithElevatedPrivileges( delegate() { using (SPSite site = new SPSite( SPContext.Current.Site.ID, SPContext.Current.Site.Zone)) { using (SPWeb web = site.OpenWeb(SPContext.Current....


2

I have SP 2010 and the alert emails do not look any different from the 2013 ones, unless I am misunderstanding your question. It is one of those things that Microsoft never updated or improved from 2010 to 2013.


1

Salve! I wanted to set up email too, for my Sharepoint. In my configuration, I used hMailServer. I realize you didn't mention hMailServer in your post, but I want to use it as an example because it represents a third-party mail server that is not Exchange, and has nothing (as you wished) to do with Active Directory. I am going to assume you have followed ...


1

if i understand you correct you want to show incomming emails into a sharepoint 2010 list? you can try the following: http://sharepointgeorge.com/2010/configuring-incoming-email-sharepoint-2010/ Email enable SharePoint 2010 lists http://technet.microsoft.com/en-us/sharepoint/ff679958.aspx Hope this helps


1

You need to define a mail server in your farm. For example WFE. Once this is decided you need to create an Alias in SMTP. IIS->SMTP->Right Click Domains->Select New Domain->Set Domain Type = Alias and provide the server name Detailed steps


1

MSG files are a proprietary format only recognized by Microsoft Outlook. The only format the Windows SMTP service understands are EML files. UPDATE You just can't save an Outlook MSG file directly into SharePoint or Windows SMTP Server. You need either an Exchange Server or any other SMTP/POP/IMAP server Outlook can communicate with. I personally use the ...


1

Judging from the link you reported, the Save method calls a FileStream object. Being a stream, the FileStream can be replaced by a MemoryStream. // Create MemoryStream object MemoryStream stream = new MemoryStream(); // Get reflection info for MailWriter contructor // [omitted for brevity] // Construct MailWriter object with our MemoryStream object ...


1

You only need to set it up on one of your servers Yes each document library will have a different email address Will be the account that the Sharepoint Timer job service is running as, as this is what processes the emails coming in and then saves them to the library


1

I found out the answer to the question of "Why isn't this working?" as well as "how to make it work": It's not working because SharePoint adds a header to the email message called X-Mailer: SharePoint Foundation 2010, and the incoming email feature will not accept emails with that header. This is apparently by design. To make it work I will have to write ...


1

Make sure you increase the logging options so you are capturing all the data with SNMP. A quick check is to telnet into your SMTP server and send a message directly to the GMAIL address and see if it is received. If you do this from Win7/8, 2008/2012 box you may need to install the telnet client first. telnet SERVERNAME 25 helo mail from:anyaddress@...


1

You will need to go to the company's website which hosts your external DNS for websitename.com. Whoever bought the DNS name should have some login credentials to access their online tools. One of them should allow you to create that MX record.


1

SMTP server that accept mail from the Internet must allow anonymous access. See example http://www.oceanapproach.com.au/blog/Lists/Posts/Post.aspx?ID=44 Edit: If you can receive email in the document library, please make sure these settings have been done: CA > Operations > Incoming email settings > Accept messages from authenticated users only: No; ...


1

Edit: the information is good, but i just checked the links and they are dead. Let me know if the basic info is enough to get you started. http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/0d263b37-f002-4d9b-a7a1-2026f032f1f7/ The second answer by Jasonzh2010 has the best information... You don't have to run SMTP on Front-End ...


Only top voted, non community-wiki answers of a minimum length are eligible