14

Delete all the console.log lines from your script. It errors out until the console is open, which is why it suddenly works when you open the console


12

I think the Desktop experience feature is not installed and Web client service might be not started so try to follow this Open Server Manager –> Manage –> Add Roles and Features. Select Features from the left step navigation –> User Interfaces and Infrastructure –> Desktop Experience. Click Next then Install. Restart Server. Go to Services by clicking ...


7

After long investigation I found solution. It is both SharePoint and IE 8 specific problem. IE 8 loads styles in different order, than IE 10. In IE 8, after my custom css, class .ms-core-needIEFilter was loaded. The class has gradient inside. I added to my custom CSS following code: .ms-core-needIEFilter #suiteBarLeft { background-color:transparent; -ms-...


6

This seems to be a problem with the SharePoint client-side code, possibly as a result of changes to support branding. I have also seen it when trying to save a page I have edited. Your choices are: 1) Set your browser to use IE8 standards - you can do this by using F12 to get the IE developer tools panel and setting Document Mode to IE8 standards in the ...


6

I think the problem may be the console.log() line. With IE, (I believe) console is only available when the debugger is opened, thus an error is thrown if it is not. Replace console.log(Status) with alert(Status) and you hopefully will see it.


5

Try using "\\" before the username when you login to the sharepoint website from client machines.


5

Sorry, looks like the answer is no. No, this is a hard limit in SharePoint. Studying the schema of the content database reveals the limit originates from the primary key columns DirName and LeafName in the AllDocs table. The only way is to work around it by creating shorter names. They do offer a link to a tool to help (see source), but not sure if ...


4

Actually, you can set it up so that you can use the Rich Text in IE9 (some people believe you have to disable it completely)! You just have to override 3 functions in form.js (I created a file called form.ie9fix.js) and make sure it loads AFTER the "normal" form.js (or form.debug.js, whichever). The functions in question: RTE_DD_GetMenuFrame() ...


4

IE will automatically log you in as the current Windows user if the site is in the Intranet zone in IE either by explicit reference in the Internet options|Security|Local Intranet|Sites|Advanced list of URL or by "Automatically Detect Intranet Network". You can change this by either removing the site from the intranet zone or by disabling automatic login in ...


4

A good description on the browser support is here. Basically SP 2010 supports IE 7+ with 32 Bit and limited support on 64 bit. Also another things is that default SharePoint master page sets the document mode to IE 8 Compatible. So even you upgrade the browser, it will work on IE 8 Compatible document mode. It can be set with following code. <meta ...


4

There are three ways in my mind if you are using an embedded JavaScript to redirect. 1. Use SharePoint Designer to Edit the Page directly. Change your JavaScript code and save. 2. Export the page using SharePoint Designer, make changes as required and import again. 3. In your IE settings, disable JavaScript on your browser. No JS will render and you can ...


4

Copy the address of a PDF file in a document library. (via the ellipsis) Go to a web part / wiki SharePoint page. Insert Web Part Media and Content > Page Viewer Web Part > Insert Edit web part keep web part settings as "web page" paste URL in the URL field click apply (resize web part height if need be) save page Office Web Apps if installed and connected ...


3

This fixed my problem.... 1) From Internet Explorer select Tools -> Internet Options -> Security tab 2) Select Local internet -> Sites -> Advanced -> 3) Under Add this website to the zone: type https://*.microsoftonline.com -> Add


3

Check this thread and answer for that: View PDFs in web browser Also consider the pros/cons for the approach (comments in the answer)


3

First off, you can use $().SPServices.SPGetQueryString rather than rolling your own Query String parser. Secondly, you should be able to just set the simple select and not worry about the hidden complex select. The $().SPServices.SPComplexToSimpleDropdown function takes care of updating the complex select under the covers. Finally, you shouldn't need any ...


3

There are some known issues with IE9 and SharePoint 2007's JavaScript, etc. You might set the IE Compatibility Mode meta tag in the master page so that it forces IE 9 to render in IE 7 or 8 mode: i.e: < meta http-equiv="X-UA-Compatible" content="IE=7" / > http://msdn.microsoft.com/en-us/library/cc288325(v=VS.85).aspx


3

This is a notorious and well-known issue in SharePoint. Background Let me explain why it happens: SharePoint is a Microsoft product, as is Internet Explorer, and it's quite a customary thing when some features work in IE but don't work in other browsers. Other browsers always were and still are "partially supported" by SharePoint. This is what happens ...


3

All SharePoint 2013 biult-in masterpages contain a meta tag: <meta http-equiv="X-UA-Compatible" content="IE=10"/> forcing IE 11 into IE 10 mode. This has been working for me without any issue, though I've also installed the ASP.NET updates to make sure IE 11 is recognized properly: http://msdn.microsoft.com/en-us/library/ie/hh869299%28v=vs.85%29....


3

I decided to give one more search for the solution before I really ask for help ticket. Luckily I found something here that exactly match with my scenario. After reading through it I also realized that my I.E. crashes as soon as I hover through a User Online Presence Control. I did have Office 2013 installed on my computer. As the blog suggests I repaired ...


3

We are testing the same thing in our farm as well. we decide to turn on the Enterprise mode(EMIE). there are many things which are not working with IE 11 in native mode. datasheet view will not work with IE 11 trying to edit the page but it fails certain webpart properties can not modified. Workflow having the issue I would also recommend you to upgrade ...


3

SP2 provided support for IE10. Since you're rolling out IE11, rather than placing the site in Compatibility View, try IE11's Enterprise Mode: http://blogs.msdn.com/b/ie/archive/2014/04/02/stay-up-to-date-with-enterprise-mode-for-internet-explorer-11.aspx


3

The new page added in layouts folder "inplview.aspx". When paging, sorting or filtering happens there is an AJAX call to the inplview.aspx and it returns a JSON based result set. That is the rows of the defined list view webpart. The "inplview.aspx" generates the "inplviewhash" tag and appends it with "#" in url.


3

I've also had trouble linking to shared drives in older SharePoint versions. It tends to flip all of my backslashes (\) to forward slashes (/), thus turning the file path into a URL. Sometimes this occurred while editing, sometimes after saving. To determine if this is the issue, hover over the link after saving or publishing to confirm all of your slashes ...


3

I realize this is very late. The above did not work for me so this was my work around: Create a shortcut to the network file Upload the shortcut to a document library in the site it is being linked to Use a link to the shortcut to the network file, in the SharePoint library, for your network file link I used this in Navigation and it works perfect.


3

If the PDF files are opened in the browser, then it means you have either configured the Permissive mode in Browser File Handling, or added the PDF extension to the allowed MIME type list. (see Option #1 and #2 in this post for details) To have the PDFs opened in Acrobat, you should disable the Permissive mode (and set it to Strict mode) and if it is ...


3

We had a similar situation with office 365 and yammer embed in IE 11. Enabling Protected Mode for the Trusted Sites Zone (Internet Options > Security > Trusted Sites > Enable Protected Mode) solved it. Apparently Protected Mode used to be on by default in IE but no longer is.


3

Internet Explorer does not implement some of the ECMAScipt 6 types used in PnP.js. Because of this you need to use a couple ployfill libraries that implement the missing types. There are a few options on which polyfill libraries you can use, I use fetch and es6-promise. Adding the following script elements to your page should get things working in Internet ...


2

Perhaps you've already solved this and moved on, but since I ended up here when searching for a solution and didn't find it, I better add my solution: A customer had exactly the same problem and the reason for it was that the customer is using a Language Pack (Swedish) on the site. Solution: Go to the user menu (upper right corner) and switch to English. ...


2

@DJ Monzyk this is a follow up javascript file as reference in previous answer function RTE_DD_GetMenuFrame() { var ifmMenu=null; var elemMenu=RTE_DD_GetMenuElement(); if (null !=elemMenu) { if (document.frames.length > 0) { ifmMenu=document.frames[g_strRTETextEditorPullDownMenuID]; } else ...


Only top voted, non community-wiki answers of a minimum length are eligible