12

I have created a designer workflow in SharePoint 2013 and i have published the workflow as a non system account (as required).But when i check the status of the workflow it say internal status suspended error 401.Following is the description of the error

RequestorId: 1fae0f8c-429f-47ca-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""],"SPRequestGuid":["1fae0f8c-429f-47ca-aa41-2293fd11f6e5"],"request-id":["1fae0f8c-429f-47ca-aa41-2293fd11f6e5"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["240"],"SPIisLatency":["0"],"Server":["Microsoft-IIS/7.5"],"WWW-Authenticate":["Bearer realm=\"4f19117b-1b7e-49c2-b6c8-72f7d425be7b\",client_id=\"00000003-0000-0ff1-ce00-000000000000\",trusted_issuers=\"00000005-0000-0000-c000-000000000000@*,00000003-0000-0ff1-ce00-000000000000@4f19117b-1b7e-49c2-b6c8-72f7d425be7b\"","NTLM"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Sat, 22 Mar 2014 11:02:22 GMT"]} {"error_description":

I have browsed through some links which say that it is because of user profile synchronization

  • I have checked that User profile service and User Profile Sync Services are started – luckydeveloper Mar 24 '14 at 8:07
2

You need to elevate Workflow permissions in SharePoint 2013 by doing the following :

  • Allow workflow to use app permissions.
  • Grant full control permission to a workflow.
  • Develop the workflow to wrap actions inside an App Step using SharePoint Designer.

For more details about How to apply the above steps check The Workflow was Suspended with Unauthorized HTTP / elevate Workflow permissions in SharePoint 2013

  • 1
    Activating "Workflow can use app permissions" feature from Site Settings > Manage Site Features, helped me to get rid of the exception. – Zakir HC Apr 24 '17 at 10:59
1

In the workflow 2013, if you have permission for a group of AD will not work. You must have permission directly or else a SharePoint group.

I faced a similar problem, only changed the scheme permission. I removed all permissions for the AD group, created a SharePoint group and gave permissions directly. Boom, it worked.

  • do you mean separate permissions for a user group in AD? – luckydeveloper Mar 24 '14 at 12:15
  • If you have in your AD a group, you can't use this group to give permission to SharePoint workflow 2013. You need give permission user by user directly or in sharepoint group of users. – Diego Hillesheim Mar 24 '14 at 12:23
1

To resolve this issue, please follow below steps:

Click on the Settings icon form the top corner and then click on Site settings.

Then in the Site Settings page, click on Site permissions from the Users and Permissions section.

Then click on the particular SharePoint group to which you want to send the email.

Then click on Settings -> Group Settings

In the Change group settings page, go to the Group Settings section and select the radio button Who can view the membership of the group? to "Everyone"

1

I followed the reference link provided by M.Qassas https://blog.devoworx.net/2016/01/31/unauthorized-http-workflow-how-to-create-a-workflow-with-elevated-permissions-by-using-the-sharepoint-2013-workflow/

and Activated "Workflow can use app permissions" feature from Site Settings > Manage Site Features.

Upon this I also configured and started my User Profile Synchronization Service. I didn't followed the rest of the article. I do not know what dependency the workflow has on User Profile Sync Service but Activating only this feature and starting User Profile Sync Service, helped me to get rid of the exact same exception.

0

That is a misconception that groups from AD wont work. Please be sure to check "Select All" for the container in the Sync Connection and run full sync. After that try and you will see, your groups would work as well. Still not working? Please open a ticket with us.

Microsoft SharePoint Admin Support.

0

Just looking at the error message one can easily say ,it is something related to Authentication,
After digging out so much inside every possible reasons and banging my head against the wall for a couple of hours , finally I noticed that the user account which was used for security token service App Pool had not enough rights on UPS, So I changed that account to the same account that is being used for UPS .Republished the workflow again and ran a test , BOOM it worked.

0

Depending on what you are doing in your workflow, you may not need to elevate to App permission. I have experienced this issue after a migration from SharePoint from one domain to another. I had a simple test workflow to send an email to an individual created in SharePoint Designer (this was my test that Workflow Manager was configured correctly). In the new environment, I finally found the problem was that the account that I was sending the email to was missing the "work email" field in the User Profile. I went into Central Admin | Application Management | Manage service application and click on the User Profile service. I clicked on Manage User Profiles, searched for the user in question and noticed the "work email" field was missing. I filled it in (yes, this is another issue since this is coming from Active Directory :) ) and saved it and the workflow worked as expected.

-2

You should have User Profile Set up and full sync run(mandatory).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.