0

I have created an approval SharePoint 2013 workflow. However, it executes all the actions before 'Send email' action but executing 'Send email' gives below exception:

RequestorId: f679ccb9-2fc0-8099-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["1058"],"SPRequestGuid":["f679ccb9-2fc0-8099-9fd6-bcce66215203"],"request-id":["f679ccb9-2fc0-8099-9fd6-bcce66215203"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4420"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Mon, 29 Oct 2018 05:09:27 GMT"],"Server":["Microsoft-IIS/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.Execute

I have even created a new workflow just to send email (hardocoded user), it logs successfully before the 'Send email' action but gives the above exception.

The SMTP is configured properly and SharePoint 2010 workflows sends email on same web applications.

I have just re-installed workflow manager and applied the CU5 updates.

The internal status is "Suspended".

Update:

I just tried to add the user into a group and checked the "Send email invitation", it doesn't send email either.

Workflow screenshots:

enter image description here

Even after removing the Email action out of the App step, issue persist.

Any help is much appreciated!

  • what is the error it is showing before going into suspended state? (check it immediately after workflow starts). – Ganesh Sanap Oct 29 '18 at 6:16
  • @GaneshSanap I have pasted the error exception above. – Sohail Shaikh Oct 29 '18 at 6:20
  • Yes, but that is the error after workflow goes to suspended state. but workflow shows the action it is taking before going to suspended state. check the information it is showing just after workflow starts and before going into suspended state. that will be helpful. – Ganesh Sanap Oct 29 '18 at 6:54
  • @GaneshSanap I have checked just after the "Started" state, but 'i' icon does not appear to check the information. The information icon is visible only after "Suspended" state. – Sohail Shaikh Oct 29 '18 at 7:09
  • strange. it should be saying like "attempting or retrying.....some action". – Ganesh Sanap Oct 29 '18 at 7:12
0

From what i know , the error is with 500 status and i can see sharepoint health score as well . Sometimes it happens because of memory related problems.

I would suggest you to test the same workflow in some other environment and with same domain account .

Let me know if you get error in other envt as well , then we can try couple of things.

0

If the email doesn't get send when you add user that means the emailing is not configured correctly. Review settings of your outgoing email.

  1. Ping the email server does it respond (if it doesn't then review firewall rules)
  2. Check with team that handles your email server do they get any errors.
  3. Review the Event viewer logs for any events when you try to send the email.
  • SharePoint 2010 workflows sends email for same web application. – Sohail Shaikh Oct 29 '18 at 9:51
  • This is strange I would focus on resolving first problem with email when you add users. In My case that resolved problems with sending emails from WF2013 – Marek Sarad Oct 29 '18 at 11:43
0

This is a common error for SharePoint Designer Workflows. The most common mistake for getting this error is "LOGGING". Logging in the workflow history is limited to 255 characters.

Re-check the logging in you workflow and if the logging content exceeds or you think will exceed 255 characters then please remove it or replace with shorter text and the try running again.

  • "Before email" and "After email" are the two logs in the whole workflow. – Sohail Shaikh Oct 29 '18 at 14:16
  • Can you post screenshots of the workflow or request header? – harshal gite Oct 29 '18 at 14:19
  • I have added the screenshots. – Sohail Shaikh Oct 30 '18 at 4:57
  • It should work. Check if both users are resolved. Try sending blank emails. Have you tried the same workflow on another site? – harshal gite Oct 30 '18 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.