1

I created a workflow.

We got a Status in the Workflow like (if Status 1 Email to xy)

One of this steps is.

If Status equals 5 
Set End Date to Today
then send an email to xy.

If User A creates the Task and set the status to 5 everything works fine. The End Date will be set right and the email goes out.

But if User A creates the Task and User B changes the Status to 5 the End Date won't be set and the Email will not be sent. The Workflow suspends.

Please help me. it drives me insane.

RequestorId: 400118c0-0cda-967b-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 401 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["208"],"SPRequestGuid":["400118c0-0cda-967b-a164-0c0bb6fb7c82"],"request-id":["400118c0-0cda-967b-a164-0c0bb6fb7c82"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"Cache-Control":["max-age=0, private"],"Server":["Microsoft-IIS/8.0"],"WWW-Authenticate":["Negotiate","NTLM"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":["15.0.0.4569"],"Strict-Transport-Security":["max-age=31536000"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Tue, 15 Nov 2016 15:49:40 GMT"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

/edit I solved the Problem. I created a spereate 2010 Workflow for the steps to set the End Date. Now it seems to work without Problems :)

0

It looks like a permission issue in Workflow History list and Task List so to overcome it follow the mentioned steps below :

  • Navigate to the site that the workflow is on in SharePoint 2013 Designer. Go to All Files -> Lists
  • Right click on Workflow History
  • Select Properties
  • Click on Permissions for this list under the ‘Customization’ section (This should open up the edit permissions page in the browser)
  • Break inheritance on this list by selecting Stop Inheriting Permissions in the new opened browser window
  • Use the check box next to the appropriate group (probably the visitor's group) to select the group that needs to be updated permissions
  • Select Edit User Permissions
  • Grant the group ‘Contribute’ permissions
  • Select OK.

Repeat the above steps for the associated workflow task list .

For more details check SharePoint 2013 workflow cancels automatically

If the issue still exists , try to review How to Elevate Workflow permissions in SharePoint 2013 as mentioned at The Workflow was Suspended with Unauthorized HTTP / Elevate Workflow permissions in SharePoint 2013

  • First of all, Thank you for your Response. But unfortunately it still doesn't work. I hope this steps will help someone else. The Thing that I don't understand is, if the creator set it to 5 it will work everytime, but if someone else (even Site Owner) set it to 5 it suspends... :( – Artur Nov 16 '16 at 7:55
  • /edit I tried to do it with a 2010 Workflow, but there it's the same Problem. But this time he fail because of wrong data Format or something like that. – Artur Nov 16 '16 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.