I have created a SharePoint designer workflow which works perfectly but as soon as i put a send email action the workflow gets suspended and gives the following error

RequestorId: 32de1e25-41e5-d9ef-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["5127"],"SPRequestGuid":["32de1e25-41e5-d9ef-8059-21f7d8d91cd8"],"request-id":["32de1e25-41e5-d9ef-8059-21f7d8d91cd8"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":[""],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Thu, 03 Apr 2014 08:06:08 GMT"],"Server":["Microsoft-IIS/7.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at

Anyone any ideas? Thanks in advance!

  • Identical the same error here in the same situation : (sharepoint 2013) Also a workflow (that should send an e-mail), that starts executing and gets suspended with internal status error code : (not using MS Exchange as mail server, Mdeamon v14 instead) RequestorId: e25ddd30-0fbe-93cd-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["71"],"SPRequestGuid":["e25ddd30-0fbe-93cd-b619-5e31
    – user29774
    Commented Jun 18, 2014 at 8:47
  • I'm seeing the same thing in a web service call activity. Have you had any luck? Commented Aug 6, 2014 at 17:03
  • i don't know why this strange error had occurred, it was resolved automatically the next day i tried Commented Aug 7, 2014 at 5:53

5 Answers 5


After getting the same error as @luckydeveloper, and having no Send an Email actions in my workflow, I finally discovered that my Log to History List action was exceeding the 255 character limit. I refactored my logging and no more HTTP 500 errors.

  • I had same issue .... we can also try to crop the text at 255 characters before logging. Commented Jul 12, 2017 at 4:27

I had the same problem and older advices did not work... after some hours of brainsqueezing I found the cause (in my case at least): in my library I had check-out required!!!
As I turned it off, all workflow started working well Set Require documents to be checked out before they can be edited to <b>No</b>

  • Hi - thanks for this. I am intrigued as to whether this might cause any other unexpected problems? Please add a small review for this, with the addition of how this can potentially cause problems this deserves an upvote...
    – Trojanian
    Commented Jun 6, 2016 at 14:25
  • Mmh.. that was the only situation I met with this issue. I can imagine, however, that mandatory checkout in a library may cause quite a lot of issues with any automated process attempting to change something on the items.
    – Marpio
    Commented Jun 8, 2016 at 8:04

Do a full user profile synchronization. Fixed it for me after SP1 installation.


In my instance, the customer had relay issues with the email server configured in outgoing email settings. Simple workflows worked fine (logging to history etc) but as soon as email was added to the workflow, I received the internal server error 500. As soon as I updated the outgoing email setting with an allowed relay partner, the workflows worked fine.



In my case, I was updating another list through workflow. Maximum length of my source field was longer than destination field length so workflow was not able to update destination field. I increased length of the destination field and then issue resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.