0

We have a document library inside our online classic team site, and it has a custom content type which mimic the built-in Document content type:-

enter image description here

Also we have the following versioning settings:-

enter image description here

Now users are able to sync the SharePoint library with OneDrvie, but the synced files will be in Read-Only mode. can anyone advice on this?

Thanks

1

1.Check if there is column set as Required, if so, make all columns are not Required.

2.Check if the Draft Item Security is set to either Only users who can edit or Only users who can approve items in version settings of library, if so, change the settings to all users can edit/view.

If the issue persists, you could remove sync-blocking column settings to resolve this issue.

References about how to remove sync-blocking column settings:

Libraries with specific columns or metadata

2
  • thanks for the reply. but based on my test if i enable content approval and i set the "Draft Item Security" to "Any user who can read items",, the sync will be in read-only,, so seems regardless of the "Draft Item Security" setting ,, if we have content approval set to yes then the sync will be in read-only... – John John Nov 23 '20 at 11:05
  • It means that after setting content approval to no, you can sync files normally. Thank you for the sharing. – Emily Du - MSFT Nov 24 '20 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.