I have a sharepoint 2010 server (Enterprise). When users try to edit word document in document library it pops up a windows which has two options read only and edit mode. When I select edit mode still the document opens in Read only mode and users are complaining that they are not able to save the document. The user has full control over the site and document library.

Users desktop is running Windows XP V2002 Service Pack 3, Internet Explorer 7 and Office 2003 (11.0).

2 Answers 2


I presume, that you see only "View in browser", Edit in browser" and "Edit in application" options under file context menu. IF any of edit option does not help you, maybe the saved file is for higher version of Office than 2003 or use some functions that can be edited only in higher version of Office. Is it locked for changes, in draft or some pending status?


The problem is due to Site collection Quota exceeding the allocated limit. I found this issue when I tried to add a Secondary site collection administrator and Central admin reported this error.

Your changes could not be saved because this SharePoint Web site has exceeded the storage quota limit. You must save your work to another location. Contact your administrator to change the quota limits for the Web site.

I went to Central Admin -> Application Management -> Configure Quotas and Lock and increased the site storage limit. After doing this sharepoint was able to open the document in edit mode. It's really strange that sharepoint doesn't log error when user tried to open the word document. And another side effect of site collection exceeding storage limit is that if you try to add an site collection administrator in Web Application (Users & permission -> Site collection administrator) is SharePoint will display a blank page if you add user and click the Ok button.

I was completely deceived by this error and started looking at some of the blog which closely matched the problem that I faced http://www.jjclements.co.uk/2010/03/24/sharepoint-2007-documents-not-opening-in-office-2007/

Hope this helps someone.

  • Thank you Kannan!!! You've saved us! It's amazing that SP doesn't give an error message about it; the wonderful thing is that the Quota was 0 (zero), but the system was in Read-Only. Terrible. Thanks again, your solution worked perfectly for us. Carlo Sharepoint 2007
    – user30314
    Commented Jul 7, 2014 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.