0

I have a document library. I edited the permissions and added a group with "read" permission.

enter image description here

So they supposed to be able to only read the documents there. If I use a test user with these permission click on the "..." there is no "Edit" only "Open". This is good. ("Share" is also a problem)

enter image description here

BUT if the test user opens it, there is a yellow ribbon at the top of the document with a button "Edit Document". If that is pushed, the document become editable and if saved, the changes appears on the site too. How can I prevent this? (The users are members of only this group) Using SP2013.

enter image description here

  • Just to confirm... these users can save back to the same library? Go to Settings, Site Settings, Site Permissions and click Check Permissions and enter your test user. Do they only have Read permissions there? – Mike Smith - MCT - MVP Mar 27 '18 at 17:13
  • Their default is "contribute", but I set them to "read" at this specific document library. (Library settings => Permissions for this document library => Stop inheritance => Customise them) The reason is that they have to fill forms (Custom lists) so they need the contribute permission by default. But this document contains helping informations to fill the a new form, so they have an option to open it during filling the form, but they should not be able to edit it. – Nefri Mar 28 '18 at 6:54
  • I created a permission group with "read" permission by default, but the result is the same. – Nefri Mar 28 '18 at 7:13
  • 1
    Okey, I got it. Probably the problem is that I just relogged to Sharepoint as a test user instead of relogged to even windows (The test ures profiles are windows lvl data and not sharepoint only). So after I opened the document as the test user (but from my own windows profile), it was downloaded to my computer. On my PC the windows recognised me as the site admin so even if I opened the document as a limited test user, when I edit & saved it, the sharepoint recognised me as the administrator and allowed to upload. So even if I am being logged in as a test user, I upload as administrator. – Nefri Mar 28 '18 at 7:50
0

The problem was probably that the users are Windows profile level database not Sharepoint level. So even if I switch user to test user with limited access in the Sharepoint, if I open a document, the access limitations are not inherited. So even if I am being logged in as a test user (to Sharepoint, but as admin to Windows), if I edit a document in Miscoroft Word, when I save it, it is uploaded to the site as an administrator upload. So I have to relog to the test user's Windows profile to be able to test elements opened in Office applications correctly.

-1

I guess you need to set view only instead of read permission, Also go through this link explaining the difference between Read and View only permission

  • Same reasult with "view only" permission. The "edit document" button is still there after opened. – Nefri Mar 28 '18 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.