3

I have come across interesting thing, that in one Document Library in SharePoint 2013, selecting Office Document default is Open and in other Edit

Default is Open Default is Edit

How can I change that default behavior in Document Library? Can't find the option to change it, maybe I'm just missing something.

Difference is, that if first selection is Open, then document will open in Read-Only mode, but if first selection is Edit, then document will be opened directly in Edit mode.

When opening Infopath document, then it should not be opened in Edit mode.

EDIT:

I have noticed, that Word document in same Library opens first in Read-Only mode and you can choose to edit it.

But Infopath forms still open in Design Mode, not just in Read-Only (where you could fill fields. Maybe this help to understand a little better of my problem.

EDIT 2:

I came up with a idea, what if I make this list into Read-Only for people, who shouldn't have edit access to there anyway, but then I encountered another interesting problem..

This picture show, when I try to open InfoPath form from list item, when I have only read access (including opening Documetns)

Environment has Office 2016 installed and InfoPath 2013 (could this cause problems?)

Appearing error, when only read only access

Found workaround!

I discovered, that this problem is with IE 11 (version 11.0.9600.18427) and somehow the problem is only with InfoPath documents, if you try open them in Read-Only permissions. It worked with same permissions on Firefox, so I tried to use Compatibility Mode and it worked with Edge mode.

It's not the solution tho, but could help anyone with same problem!

  • are you talk about Default open behavior for browser-enabled documents: – Mohamed El-Qassas MVP Aug 12 '16 at 10:27
  • Commented on your answer – Taurib Aug 15 '16 at 7:29
1

I did it! Problem was that master page had following tag

<meta http-equiv="X-UA-Compatible" content="IE=10" />

So this forced this to work with IE 10 mode and following feature was bugged in that mode. So instead I changed that tag to following:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

You can change your MasterPage content in SharePoint Designer and changes should affect instantly (you may need to check in).

NOTE

This is solution to my problem, this might help others. You can test it out, if anything works with different compatibility with F12 tool.

0

If you talk about the Default open behavior for browser-enabled documents

  • Go to list settings > Advanced setting > Default open behavior for browser-enabled documents:

enter image description here

  • This doesn't exactly change, if document is opened in Edit or Read-Only mode. – Taurib Aug 15 '16 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.