0

My goal is to enable e-mail notifications to external users in SharePoint online.

This is done with success with admin account. But if a regular user inside the organization want to set up notification for external account she gets an error: "Sorry you do not have permission".

And if I go to admin account to check the test folder permissions it says "full access" under permission level.

Yes she can ask for permission, and it is request for is groupwebsite (I hope it is understandable translation) and then I have to select from the drop down list but what more can I give after "full access"?

1
  • Can you share more information about your requirement? For example, are you setting “user alert” for external users, sending email while sharing folders to external users or in other scenarios? Which page/setting is the user trying to access when running into the "Sorry, you don't have access" error? Nov 20, 2020 at 7:07

1 Answer 1

0

I would suggest you switch to another user account with Full Control permission and test again.

Or you can remove the issued user from this site (via user information list: _layouts/15/people.aspx?MembershipGroupId=0) and then reassign permission to see if the issue persists.

In addition, if you are settings alert for the test folder, the external users need to be in the organization directory already (guest users).

2
  • I created a new folder as admin. I disabled the permission inheritance. I removed everthing, and added myself (admin account) with full acces. Then added the user with full access. Signed out, signed in as user, tried to set up notification (for external accont) as the user (not admin), not working. The external user is already added to the organization directory (if were not you can not choose it from the drop down list as you start to type the name). If I press request permission (as user) and go back to admin account, I am seeing that the requested permission is not asked for the user.
    – petersonal
    Nov 20, 2020 at 12:02
  • @peterssonal Do you have the “Limited-access user permission lockdown mode” feature activated? Deactivate this feature if so. Also there is another post of similar issue, hope it might do some help: social.technet.microsoft.com/forums/sharepoint/en-US/… Nov 26, 2020 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.