0

After sharing a Sub-Site with an external user (requiring Microsoft live login) the external user cannot access a document library within the site.
I'm getting the "Sorry, you don't have access to this page" response.

Initially, when I tested sharing on a different site collection, the external user could access the library fine.
Differences between test library and current library:

  • Current library has Approve/Reject and Versioning
  • Current library has a Column (defined at the top site) that is a lookup to a list (also on the top site).
  • Library page has a Query URL String web part which provides a filter targetting the lookup column.
  • Library has 2010 and 2013 workflows.
  • Librarys new and modify form have been modified through web-editor, runs Javascript.

Top Site** - ListA - Int Sites - Ext Site Hub - Ext SiteB - LibraryC

List A is at s.sharepoint.com/sites/Top/Lists/ListA
External Site B is at s.sharepoint.com/sites/Top/Ext/ExtB
Library C is at s.sharepoint.com/sites/Top/Ext/ExtB/LibC
**Columns and Content Types for LibraryC are defined here

In O365 Admin I have selected Allow external users who accept sharing invitations and sign in as authenticated users.
The in SiteB I clicked the Share button on the site ribbon (next to the Follow button), and invited the external user, assigning them to Team Member (Edit).
Once the email arrived, I followed the link making sure to log in the with the correct Live account.
This took me to SiteB, and when I tried to navigate to the library, I got Page permission error.

I have tried removing and re-adding the users permissions. I have tried making the site/library permissions unique/inherit.

What have I missed?
Is this actually possible?
Has Sharepoint hidden some weird set of permissions for this?

Any help is appreciated.

0

Turns out:

Quick Links are different between different people/groups. The Library wasn't showing in the Quick Links so I assumed that I couldn't access it.

Document Version Draft Item Security was set to Approve + Author only. When following a direct link, it would take me to an empty library.

Solution: Setting Draft Item Security to 'Any user who can read items' and adding the library to the other users quick links.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.