0

I have created the list workflow and just printing the history log to print a test message. I am trying to publish the workflow using my account but it always returning me below warning error message.

You do not have permission to do this operation. Ask your site administrator to change your permissions and then try again, or log on with a user account that has this permission. To log on with a different user account click OK.

I did below workaround but did not get work:

  1. Checked the site permissions for my account, all permissions are working correctly. I have full control, design and contribute access.
  2. Checked the permissions for SharePoint designer, this is working fine. I am Primary administrator from central admin.
  3. Checked the application pool. This is working fine.
  4. Reset the IIS.
  5. Also restarted the server as well once.

Can any one please advise what is the exact issue here?

enter image description here

0

Whether this issue occurs on all workflows?

1.Go to Site settings -> SharePoint designer setting under site collection Administration -> Check all the options -> Click ok.

2.Try to uninstall SharePoint Designer and re-install again with a windows restart.

3.Check ULS logs.

2
  • Actually I am testing a workflow on my dev test site. Issue occur only for this particular site only. – Mobile Test Sep 30 '20 at 3:18
  • Have you check the first two suggestions? Any clues in the ULS logs? – Emily Du - MSFT Oct 1 '20 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.