0

I have a problem with Audiences of SharePoint Online in Office 365.

I have a custom list, to segment the data, i modify the default view to group the rows by the field "Gerencia" (Management)

The groups of rows

There is two managements, "Canales" (Channels) and "Riesgo" (Risk), i allow the audience target and i put one SharePoint Group for each Management, they call "Gerencia Canales" and "Gerencia Riesgo", respectively. Those group only have "only read" permissions.

Audiences

However, the group of risk management, insert of not be able, still be able to see the rows with the group of channels management.

Can you help me with my problem? Thanks in advance.

Edit:

enter image description here Members of "Canales".

enter image description here Members of "Riesgo".

0

This is a default behavior in SharePoint.

If any user/group is having Read permission on the SharePoint List then they can see all the items in that particular list.

If you want to hide some items from particular groups then you need to use Item level permissions in SharePoint (Difficult to manage if the list items are more).

You can read more about SharePoint permission inheritance, permission levels and customizing SharePoint permissions in below official documentation by Microsoft:

  1. What is permissions inheritance?
  2. Understanding permission levels in SharePoint.
  3. Customize SharePoint site permissions.

You can read about Item level permissions in below article:

How to Use SharePoint Item-Level Permissions.

| improve this answer | |
  • I try to add this, and doesn't work, there is any specific permission can help my? – Hernan Oct 28 '19 at 2:20
  • I break the inheritance for this, i kicked the gruops with the option "remove user permissions", and readded with the "grantt permissions" option – Hernan Oct 28 '19 at 3:54
  • You need to do that for each individual list item to restrict the permissions and not for whole list. Is it working for you now? – Ganesh Sanap Oct 28 '19 at 4:53
  • Stupid questrion, how i do that? I don't found the option for a permissons in a list item – Hernan Oct 28 '19 at 14:00
  • Check "How to Use SharePoint Item)-Level Permissions" link in my answer. – Ganesh Sanap Oct 28 '19 at 14:56
0

From your description, you set the group of risk management with read permission on "Riesgo" (Risk), and set the group of channels management with read permission on "Canales" (Channels). But the group of risk management still be able to see the rows with the group of channels management.

For your issue, make sure the users in the group of risk management don't exists in the group of channels management.

| improve this answer | |
  • The members of Risk management aren't in Channels management and vice versa. I add two photos with the members of each group, the common user is me, because i need to see all the rows. – Hernan Oct 24 '19 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.