I'm trying to create a modern page in one of the site collections

I checked the site settings and the "Site Pages" feature is active

enter image description here

But when I try clicking on the "Add new page" it only creates a normal page and it's not creating a modern page

Even in the Sitepages Library I don't get new site page option under the new ribbon, even though the content type is attached to the library


1 Answer 1


That's probably because you dont have the setting enabled at the tenant level.

Go to you SharePoint admin center > Settings and then modify the Site Pages setting to Allow users to create Site Pages.

The admin center settings url would be:


enter image description here

Once you change this, wait for a couple of hours and then you will be able to create modern site pages using Add a page option or via the Site pages library

  • should I do anything else after changing it in site settings level? Commented May 30, 2018 at 14:11
  • Nope, once it is set at tenant level, that option will appear in few hours. No need to change anything at site level, just keep the site pages feature activated. Commented May 30, 2018 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.