1

I cannot add a "Site Page" for the modern UI. I've looked through some articles including this one: Not able to create Modern UI Pages in Pages Library/Document Library.

I don't get the option under the "New" button, even though it shows in my Content Types, as you can see from the images below.

enter image description here

enter image description here

0

To troubleshoot the issue, check things below:

  1. Switch to classic view, and check if you can create the site page in the site pages library.

  2. Remove the “Site Pages” content type and re-add the “Site Pages” content type in the site pages library.

  • Remove and re-adding seemed to do the trick. However, it did take some time to populate the option to select "Site Page". – Resco Dan Jan 20 '18 at 16:33
0

"Site Page" Content type which allows you to create Modern UI Pages, will automatically get added to "Site Pages" Library and will be visible under "New" button only when you activate "Site Pages" Feature at web level.

You can find the feature at
https://companyName.sharepoint.com/sites/siteName/_layouts/15/ManageFeatures.aspx enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.