5

I have a SharePoint 2013 Farm with 4 WFEs and 3 App Servers which has one web application with the migrated content from SharePoint 2010. (Migration done using the content database detach attach process).

All content has been restored successfully and most of the functionalities are working as expected.

when trying to add a new folder in any document library in site collection level or any of the sub-sites it throws

"The server was unable to save the form at this time. Please try again."

I have tried all the solutions and workaround suggested across the blogs like ,

  • IIS reset ,
  • Restarting Search Host Controller service
  • Enabling/Disabling HTTP Activation feature in .Net 3.5 and 4.5 in Server Manager
  • Restarting all the servers in the farm
  • Creating a custom permission level with "Use Remote Interfaces - Use SOAP, Web DAV, the Client Object Model or SharePoint Designer interfaces to access the Web site."

in logs i'm getting messages related to "access denied to /_vti_bin/client.svc?ProcessQuery".

but still the issue persists can't able to get rid of this issue.

Need our SharePoint techies expertise to solve this.

Thank You.

  • Can you provide an ULS-Log of the whole Correlation?! – MHeld Jan 24 '18 at 12:13
  • I have the same issue on SharePoint 2016. Nothing helps. Can't find the solution... I got that error message in Chrome and Safari browsers using extended web application URL (extranet). Using Internet Explorer everything works well. But one user has Mac and he can't use IE... – martusha Feb 21 '18 at 12:29
  • yes in my case as well I tried all the solutions provided throughout the blogs nothing helped, and finally, I got to know that the issue was due to some network policies which was blocking the request internally to the client.svc , and with the help of the network team, we resolved the issue. check this option as well. – Esaki Feb 22 '18 at 11:54
2

Most of the proposed solutions have already been implemented and so next to what you did, try the following

  • Enable anonymous authentication for the website in IIS for each WFE SharePoint Server in the farm, Then Restart IIS.
  • Make sure that there is a sufficient space in the database servers!
  • Set the minFreeMemoryPercentageToActivateService="0" in the web.config
  • Make sure that the web application is claims-based authentication, for more details check Migrate from classic-mode to claims-based authentication in SharePoint 2013

For more details check The server was unable to save the form at this time. Please try again.

  • Thank you for your reply on this , i tried all these as well now but still the issue is there , is there any relation to distributed cache and this because same content we restored in a dev environment there it works fine which is a stand alone server but in production with multiple front end it make issue – Esaki Jan 22 '18 at 8:16
  • for your info if i try to create a folder using csom console application it works and doesn't throw any error . i'm wondered now bcs csom again internally uses client.svc service and works fine then why its not happening while trying to create from UI – Esaki Jan 22 '18 at 9:45
  • @Esaki So wired, could you try to create a new test web application with its root site instead of the migrated site, and check if you face the same behavior or not? – Mohamed El-Qassas MVP Jan 22 '18 at 9:56
  • Comments are not for extended discussion; this conversation has been moved to chat. – Mohamed El-Qassas MVP Jan 22 '18 at 9:57
1

I'm a newbie on SharePoint, but I've googled and have found a Spanish article talking about this error. Basically the guy says that he got this error because SharePoint has a limit of items by list by default, so when a user wanted to see all items, the user couldn't, and SharePoint logged the error. So, he only just had to increase the size of items at the corresponding level (web application in his case).

Maybe, the document libraries where you are receiving the error, they have thousands of documents, and actually limit item by default is lower. Try increasing it.

Spanish source: http://jmhogua.blogspot.com.es/2016/05/como-resolver-el-error.html

Sources inside:

  • Thank you for your reply on this but the document library im trying to create a folder doesn't have these many items only it has some 5 docs – Esaki Jan 22 '18 at 8:19
0

After a long troubleshooting and trying all those suggested ways there was no luck.

and we were getting the below message in the process query call when trying to add a folder or in drag and drop multiple files uploads.

/_vti_bin/client.svc?ProcessQuery

The requested URL was rejected. Please consult with your administrator.

Your support ID is: 5467528288334050234

we shared the support id to our network team then we came to know that there are some network policies applied on this dns given for the site which restricts some edit functionalities in the sites.

then the network team provided us a different domain without these network policies and now all these issues are resolved and it works as should be. Wierd.

again it was up to my environment, hope this will help us to look this issue from another perspective as well.

Thank you guys for your help.

0

Please check if the user has access to the libraries that contain user interface elements. Such as images, icons, etc. In my case user didn't have access to PublishingImages library where site logo was stored. Once access has been granted, the problem disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.