1

I have copied over the database of SharePoint Standard server to recreate the web application for a new environment. All setup and configuration have successfully been executed and I can see the site as it should be.

However, I encountered a problem wherein I was not able to add/edit list items to majority of my lists. I already checked for the common things related to the error (see title) such as restart search node controller, perform iis reset, restart server, ensure memory is sufficient (currently only using 55% so should be enough), ensure that user has full control over the list. but still failed. I do not have any add on in my internet explorer and is running on compatibility view. No ULS log record to track, no event viewer record to track as well, I am totally clueless.

I have also did the same for Foundation and the foundation server is working properly, no such issue encountered.

Any tips or suggestion is mostly welcomed.

*Update: All web applications are consistent with the problem. I can upload documents but I could not modify its properties.

  • If it is for all lists, make sure content databases are not read-only – Robert Lindgren Aug 1 '14 at 9:08
  • Thanks for the feedback but the content DB is not read-only checked in central admin. I also confirm this as I can add/edit in one of the list – Joe Aug 1 '14 at 9:24
  • Try this below url it worked for me. sharepointerthilosh.blogspot.in/2013/03/… – Ramesh Dhanabal Aug 5 '14 at 10:55
  • Hi Ramesh, thanks for the feedback but it does not work as mentioned in my descirption – Joe Aug 11 '14 at 8:22
0

You probably checked but I'm pretty sure insufficent free space on the HDD can cause this problem.

| improve this answer | |
0

You migrated this Database from different farm,right?

couple of things to check...

  • Make sure quota for site collection is not maxed out
  • is this behavior for every list or whole site collection...check from central admin if site is marked as read only.
  • Make sure not too much stuff in the recycle bins.
  • create another view in List(if couple of lists are complaining) then try it.
  • check the ULS Logs / event logs at the same time when you encountered the problem
  • please share the error you are getting.
| improve this answer | |
  • Yes, I am creating a new environment. The database is used to restore the site collection. Quota is set to no quota checked via configure quota and locks. Only for the restored site collection, I already checked based on Robert's comment and is not read only. I deleted all items in recycle bin, I also tried to create a view. No errors found in ULS/event logs. It's happening on majority of the list, so far I have only found one list that is working fine. Not really sure what else to check, I am suspecting it might be a DB issue, but corrupted DB should not work at all, any thoughts? – Joe Aug 4 '14 at 1:20
  • i have recreated it on a new environment and it was working fine, database is not the issue – Joe Aug 4 '14 at 17:09
0

I have reinstalled my SharePoint on a fresh OS while retaining my SharePoint Farm (since my DB is located on another server) and all seems to work fine now.

Before I reinstalled, I installed it on my local VMs just to make sure that DB has no problem.

I did encounter my services being down, so I recreated some of the them then everything is ok.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.