1

After rebooting our multiserver 2013 farm, the Search Administration page shows the following error:

Sharepoint 2013 search error - The search application 'Search Service Application' on server is not provisioned.Confirm that the Microsoft SharePoint Foundation Timer service and Central Administration service are running on the server.

Queries are possible, but no new content is being crawled. When I click Content Sources I get an exception which looks like this in ULS:

WcfReceiveRequest: LocalAddress: 'https://server.x.net:32888/cff12e32958241e4c109e0df0dc48f8a/SearchAdmin.svc' Channel: 'System.ServiceModel.Channels.ServiceChannel' Action: 'http://tempuri.org/ISearchApplicationAdminWebService/GetVersion' MessageId: 'urn:uuid:6be9d3a7-34e9-403e-aa83-136cccfd784d' 7abaeb9d-73c5-0068-64e4-feed937aadc2

Unable to find application '5c953f20-24e7-48c1-a404-e633d987fcc1'

What kind of application is it that cannot be found? We have tried reboots, clearing config cache and are getting desperate as this is our production environment and no new content is being crawled.

Update: This guid reveals itself to be the index guid. The index itself is partitioned over two backend servers and seems to be in working order when looking at the Search Topology diagram on the Search admin page.

Update2: We also have the following error in the event log, recurring with high frequency:

Search not provisioned: There is no project Portal_Content mounted under gatherer application

0

Turns out the Search Administration component on one of our app servers was not working properly. The following actions helped our situation.

On the server with the primary Search Administration component:

    (Get-SPFarm).Servers["SERVER5"].ServiceInstances | Where {$_.TypeName -eq "Search Administration Web Service"} | Stop-SPServiceInstance

On the other server:

$varinstance = Get-SPEnterpriseSearchServiceInstance -Local
$varsearchapp = Get-SPEnterpriseSearchServiceApplication "Search Service Application"
Set-SPEnterpriseSearchAdministrationComponent -SearchApplication $varsearchapp -SearchServiceInstance $varinstance

After these actions I was able to access my content sources and start a crawl. The Search Administration component on the faulty server thereafter started by itself.

  • I am facing the same issue, can you explain what exactly you did? Why did you stop it on primary server and what did you do on other server? – Achiever SP Jul 4 '18 at 15:06
  • This was a while ago now. I only recall that I desperately tried a lot of actions to get it working and finally succeeded after executing the commands above. – SilvioDante Jul 5 '18 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.