4

I have configured SharePoint Foundation 2013 farm and created Search Service Application through the Central Administration Configuration Wizard by deleting the previous created Search Service Application because that was stuck in 'Paused For : External Request' and we were not able to resume the same.

Now, Search service Application starts appearing in list of Service Applications, However, when I click on Search Service Application I am getting below error.

"The search service is not able to connect to the machine that hosts the administration component. Verify that the administration component 'GUID' in search application 'Search Service Application' is in a good state and try again."

Any help is rally appreciated.

5

Couple of things to check.

Solution # 1 simply change the application pool to use SharePoint Web Services System for search service applications and check.

  1. Go IIS
  2. In IIS > Expand server > Expand sites > Expand “SharePoint Web Services
  3. Now check all the GUID 1 by 1 in content view unless you find searchadmin.svc and searchservice.svc
  4. Right click GUID go to advance settings
  5. Change the application to “SharePoint Web Services” > Click OK

Solution # 2Enable the timer job and do IIS reset:

  1. Run below PS command to enable the service.

  2. Enable-SPTimerJob job-application-server-admin-service

  3. Result ==> IsDisabled: False
  4. Do Net Stop sptimerv4
  5. Do Net start sptimerv4
  6. Do iisreset

Solution 3

Ensure the account has full control permissions on the Search service application and IIS account used by this service application

  1. Open Central Admin > Select Security > Select “Configure service accounts”
  2. Select the search service application
  3. For “select account for this component” Select a account which has full permission

SharePoint Server: "The search service is not able to connect to the machine that hosts the administration component"

  • Checked all these settings, but no luck. I had deleted the previous search service application which was stuck in 'paused for:external request' state and re-created this new search service application through Configuration wizard in SharePoint Foundation 2013 and this is causing above problem. – Amol Kadam Feb 12 '16 at 9:55
  • how many search application you have now – Waqas Sarwar MVP Feb 12 '16 at 16:38
  • Only One Search Service Application that I am having in the Farm. – Amol Kadam Feb 15 '16 at 7:07
2

You should run the psconfiguration wizard once and that should definitely solve your problem.

1

What solved it for me: moving the SearchAdministrationComponent back and forth

Add-PsSnapin Microsoft.SharePoint.PowerShell -ErrorAction SilentlyContinue
cls


$ssa = Get-SPEnterpriseSearchServiceApplication "Search Service Application"
$admin = Get-SPEnterpriseSearchAdministrationComponent -SearchApplication $ssa
$admin | Set-SPEnterpriseSearchAdministrationComponent -SearchServiceInstance SERVERNAME -Force 

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.