0

I am developing a company's SharePoint online site for internal communications. I have Full Control permissions to the entire site. I created a list called HR FAQs and want to grant editing permissions to only users with Full Control, plus an "HR Managers" group that has Edit permissions.

When setting up the list, I changed the label of the "Title" column to "Question," and added a required column called "Answer" of the Type Multiple Lines of Text, with the lines expanded to 9. In addition to being a member of the HR Managers group (temporarily, for development purposes), I have granted myself Full Control permissions to the list (in addition to already having Full Control of the entire site).

The problem comes when I try to add some dummy items to test and demonstrate the list to the HR team. I click "Edit in Grid View" and can enter a question, but then the Answer column is labelled as "read only," and I cannot update it. If I try to add questions one by one, using the standard form, I am able to add both Question and Answer.

Does anyone know why I can't edit all columns in this list in Grid View or Quick Edit mode? Is there any workaround?

Image of: FAQ List in Grid View Showing Read-Only Column

0

Per my test, I have the same result with you when we select the multi-line column type as Rich text:

enter image description here

And per my research I found this is by design,we can't edit the multi-line text with rich text (Bold, italics, text alignment, hyperlinks) type in datasheet view.

enter image description here

As a workaround, change the type to Plain text or Enhanced rich text(Rich text with pictures,tables,and hyperlinks)

Similar issues for your reference:

Read Only in Datasheet view

https://social.msdn.microsoft.com/Forums/sqlserver/en-US/45fd8464-9daf-47b7-9e35-326f3b771882/quotrich-textquot-field-will-be-disabled-inside-the-quick-edit-grid-while-quotenhanced-rich?forum=sharepointdevelopment

1
  • Enhanced Rich Text seems to work. Thank you! May 19 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.