1

I am new to SharePoint online and it is one of the most confusing ones.

I imported an excel into my SharePoint list which has the data about my company's employee's leaves. My requirement is that my HRs and top-level managers should be able to view all leave balances while other users should be able to view theirs individually.

So far I tried the following:

List Settings> Advanced Settings and did the following enter image description here

Then I went to Views>All Items and did the following

View

This helped me view only my leave balances.

Then I went to List Settings>Permissions for this List> Break Permission Inheritance. I created a group called 'Owners' which contains name of all those who should be admins that can view list entirely and assigned them permissions of Full Control,Design and Manage Hierarchy.

And implementing all these I still find that users can only view their own leave balances.

How should I be able to assign specific permissions to owners and individuals to already existing list?

0

To override those settings, the user needs the Manage List right. Once you assign that right, you'll be able to see all items.

  • Where is that right present in Sharepoint online? – Sahil Tiwari Mar 27 at 15:38
0

You need to create custom roles and assign these separately to different groups of Admins and normal users.

YourSitecollectionpath/_layouts/15/editrole.aspx?role=

enter image description here

  • Hi I am unable to find it. Can you tell me where this page is present in Sharepoint Online? (Like the path not url) – Sahil Tiwari Mar 27 at 15:57
  • Go to Site Settings > Site Permissions > Permission levels (in the top ribbon) > click on the permission level you want to change – Murtuza Husain Mar 27 at 16:01
  • It's still not working – Sahil Tiwari Mar 27 at 16:22
  • There are 2 manage permissions. Hope you changed both – Murtuza Husain Mar 27 at 16:24
  • Yes I changed admins/owners to Full Control, Design and Approve permissions. For other users, I only selected 'Read'. – Sahil Tiwari Mar 27 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.