2

I have granted user with full control access on a subsite. But she is not able to see edit page option in gear icon --> settings.

I have checked permissions and it shows up that user has full control access. As a test, I created a new subsite and granted same full control access and asked her to test again. But same issue and she does not see the Edit Page option in the settings.

Can anyone help me figure out what is going on? Thanks for your help in advance.

1 Answer 1

1

Check this:

  • If user has permissions on Site Pages library
  • If user has permissions on site pages library, check user permissions on individual site pages

If user has permissions on Site Pages library:

  • Go to Site pages library
  • Click on settings (gear icon)
  • Select Library settings
  • Select Permissions for this document library
  • Check if site pages library inherits permissions from site. If not, check user permissions using Check Permissions

enter image description here

Check user permissions on individual site pages:

  • Go to Site pages library
  • Select site page --> click on ellipses (...) --> select Manage access
  • Click on Advanced at the bottom of the panel opened at right side of screen.
  • Check if site page inherits permissions from library. If not, check user permissions using Check Permissions
3
  • Thanks for your quick response! I have checked Permission on subsite andcpage library. It shows as user has full control access but she is not able to see edit page in the settings
    – Rupa 91
    Apr 20, 2021 at 18:05
  • Does she have permissions on individual site page as well? Is there any workflow/flow added to pages library which breaks permissions? Or any code customizations on page to hide Edit option conditionally? Apr 21, 2021 at 3:07
  • Hi Rupa, were you able to solve your issue? Apr 27, 2021 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.