As a site collection admin, when I go into subsites and choose "Edit Page", and the "Insert" tab, I see a long list of categories for web parts in the left hand panel. However, when I log in as a "Full Control" site manager, those categories aren't visible, I only see "Lists and Libraries" category.

I've checked this through two site collection admin accounts and both accounts show all web part categories. Full Control users can't see the categories.

Any ideas where to check?

4 Answers 4


Try checking the permissions of the webpart gallery at your site collection root:



I tracked it down to the web part gallery, not at the permission level, but at the site level. I hadn't given NTAuth access to the web part gallery.


Don't add users to the side admins group even though that's a sure shot success.

Just add the specific group with "read" permissions to the Master pages gallery , I don't advice adding the Nt authority authenticated users as read to this library. But if the site is used by a larger audience then well worth adding.

Otherwise just add the users/ troubled group with read permissions. This works and I have taken this resoluion from an article from Nagesh HTH.

It's in the site settings > Under Galleries > Master pages and page layouts > Permissions


Sometimes, your SharePoint page is added with the master page (custom) change the master page to default, and then try to add web part

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.