0

I have created a page layout that (among other Things) have three web part zones.

If I use this page layout on a page, I can easily add web parts to the zones. But trouble is, I'm not the one, who needs to do this. For this I've created a user Group, giving them Full Control to the site containing the page. But, when they edit the page, the web part zones are not even shown!

I tried giving the same users Full Control to the masterpage gallery to see, whether they needed some kind of extra access to the page layout. No luck.

The web part zone has all the trimming to be editable in the page layout:

AllowLayoutChange="True" Visible="True" AllowCustomization="True"
AllowPersonalization="True" FrameType="TitleBarOnly" LockLayout="False" 

I also tried giving the users Full Control to the Web Part Gallery to no avail.

Hope somebody can help!

0

You can set permissions directly for your page layout within SharePoint Designer, but it's no a solution for you. (SharePoint Designer -> Page Layouts -> Permissions -> Stop Inheriting)

You have to give
1. full control 2. Contribute 3. Designers Group Permissions

in order to be able to work on webparts

  • Is there no way to avoid using SharePoint Designer? – thewolf May 8 '15 at 12:33
  • you can go to Site Settings-> Galleries->Masterpages and page layouts and from the you can go to library settings and assign the permissions. if you dont want to use sharepoint designer. And to assign Designers permissions you can go to the Site collections -> Site Permissions and there will be group called as Designers which is SP default group you can add names of the people in this Group whom you want to be able to edit the webparts . – Manish Oswal May 8 '15 at 13:00
  • Hi. Sadly, it doesn't Work. My user has designer on both the site itself (containing the page with web part zones) and to the masterpage library on the site Collection. – thewolf May 11 '15 at 12:42
0

So... this had nothing to do with SharePoint apparently, as other users with Edit permissions WERE able to add web parts to the (visible) web part zones.

We're guessing that out test user has some sort of IE policy setup that is different to regular users.

So thanks to all for their help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.