Does anyone know what's the problem with a workflow (or sharepoint itself) if I cannot publish a workflow. If I check for errors I get a message that no errors are found and saving the workflow works. But even with the simpelest workflow I cannot publish it (for example with one action: Log to the History list or setting a workflow variable)

If the problem is in sharepoint, is it possible to fix in Office 365? (so without web.config,...)

The error:

Errors were found when compiling the workflow. The workflow files were saved but cannot be run.

.. and as advanced message in this error:

Could not publish the workflow because the workflow configuration file contains errors.

  • So is SPD workflow. Don't you have anything in RED showing? Try searching next to the location where you've changed. ..and NO, Office 365 would not help at all as long as your workflow has issues. Apr 24, 2012 at 17:28
  • Is this a permissions issue?
    – Kit Menke
    Apr 24, 2012 at 18:06
  • I personally suspect changes in Worflow (e.g. occasionally depending on the type of change in the OOTB Approval workflow you get errors related to the Duration choice field ) Apr 24, 2012 at 19:04
  • Which version of SP are you using? Foundation/Standard/Enterprise? 2007/2010?
    – dwwilson66
    Apr 26, 2012 at 13:56
  • I tried it in office 365: sharepoint online, but maybe Patrick_J had it somewhere else? (he put bounty on this question) Apr 26, 2012 at 15:10

3 Answers 3


The problem may be with the SharePoint installation itself. If you cannot publish a workflow on any of the web applications in the farm, I think the best way is to reinstall OS and Sharepoint.

Otherwise, You can also try below :

  1. Create and publish a workflow associated to a list on another SharePoint farm if you have.
  2. Open the site(where workflow is published successfully) in designer and Go to All Files>Workflows>[YourWorkFlowName] folder.

  3. Copy (all three files the folder in Step2) and Replace them at the SharePoint site(where you have problem) at All Files>Workflows>[YourWorkFlowName] folder.

  4. Replace the guids,Id and description with the actual in the new .xoml.wfconfig.xml (which you copied) in the <Template> and <Association> Tags . For this you can back up below information before replacing .xoml.wfconfig.xml.

    Template BaseID="{EA36B899-39E1-4222-B9CE-88341E9A3898}" DocLibID="{48F49FA8-E7DB-4D5E-B248-9CC24BC8BAFA}" TaskContentType="0x01080100C9C9515DE4E24001905074F980F93160" Category="List" Name="Workflow 1" Description="" XomlHref="Workflows/Workflow 1/Workflow 1.xoml" XomlVersion="V1.0"/>

    Association ListID="{213B5516-238B-45B3-AC17-A68CDC0A3A96}" TaskListID="{CAFDFF34-A25C-4300-BC04-9FF7C319B8BD}" StartManually="true"/>

  5. Now try to save the workflow and publish


Another way I just stumbled upon to fix this is to copy and paste all the files within SharePoint Designer (it will call it "Your workflow Name Copy 1")

Then use the copy


In my case it turns out that there were too many previous workflows on the list itself. I removed most of the old workflows which were instances of the same workflow I was attempting to publish. I ran the publish afterward removing most of the previous instances with success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.