0

enter image description hereI have written two SharePoint 2010 designer workflows both of which send emails to external users. The problem is both workflows are not getting started when I update the list item. One workflow is of simple one step which sends email. Also I have put logs there when workflow starts and ends, but no logs are added to Workflow History list. There is also one error coming when I publish the workflow "Errors were found when compiling the workflow. The workflow files were saved but cannot be run.". This workflows are built for SharePoint online list. Any help would be appreciated.

  • It will be easy for us to answer your question if you can add the screenshot of actions you have used in your workflows as you are saying you got an error while publishing the workflow. – Ganesh Sanap Mar 22 at 13:37
  • The workflow only has one step of sending email to external user. And two log actions one at start and the other at end after the email action. – Niranjan Kulkarni Mar 22 at 14:21
1

The last time I checked, the issue with SharePoint 2010 workflow on Office 365 has been resolved. I will suggest you clear SharePoint designer cache, edit the workflow again and publish it again. Check the below link for how to clear SharePoint designer cache:

https://stackoverflow.com/a/43113779

  • Its working now the issue has been resolved thanks :) – Niranjan Kulkarni Mar 25 at 11:24
1

There has been an issue with SharePoint Workflow 2010 platform from Microsoft for about two weeks now. It has been logged on the admin center as seen in the image below.

enter image description here

If you have access to the Admin center of Office 365, you can also check this out in the service health section. Hence, when you try creating a new 2010 workflow or edit an existing one, you get this error. I'll suggest you recreate the workflow on 2013 platform if it's not too complicated as this is not affected. Hopefully they get it resolved it soon.

  • 1
    Yes thanks. But the thing is email to external users are not sent through SharePoint 2013 workflow. That's why I created 2010 workflow. – Niranjan Kulkarni Mar 25 at 8:46
0

There is an issue published via Office 365 Admin Center->Health->Service Health->Advisories->SharePoint Online:

Users are unable to edit workflows or create new workflows in SharePoint 2010 using Designer and other protocols.

Current status: We have validated that the deployment is approximately 96 percent complete.

We currently anticipate that the deployment should complete by Tuesday, March 26, 2019 as the fix propagates through the remaining systems.

Once the fix reaches your environment, you will need to republish any workflows.

I have done a test in my SharePoint online and it works now. You can check again.

0

We are still facing the issue. Apparently it is removed from MS Service Health Advisory. However, the issue still not resolved.

We had been patiently waiting since last three weeks for this to resolve and this is badly impacting the business.

Waiting to hear from MS team with a fix.

Thanks, Jame

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.