4

I have created a modern team site inside our SharePoint online tenant. and using the office 365 admin, who is also the site collection admin, i try to login to the site using SharePoint designer, as i need to create some list workflows. But i were not able to login, where i got this error :-

403 FORBIDDEN403 FORBIDDEN403 FORBIDDEN403 FORBIDDEN403 FORBIDDEN

and this message:-

enter image description here

can anyone advice on this please? i know to be able to access a site using SP designer, the user should have atleast Design permission level, and in my case i am the site collection admin.

Thanks

2
  • Same problem here, none of the below answers (three so far) work for me. – Mohsen Sichani Mar 16 '20 at 20:47
  • Hi @MohsenSichani just added another answer for the fix that worked for me - try that one – PerryW May 4 '20 at 7:57
0

In your Site settings, Access to SharepointDesigner should be enabled

section > Site Collection Administration > Sharepoint DEsigner parameters

5
0

Please try to access the site in the browser and check if you can edit the site in the browser.

Then check if SharePoint Designer is allowed at web application level and at site collection level.

Thread with similar issue:https://answers.microsoft.com/en-us/msoffice/forum/msoffice_sharepoint/sharepoint-designer-2013-multifactor/bf47ba65-b252-43db-8421-dc7a7f155a15

Are you using MFA? If so, SP designer does not support MFA. You will need to use the app password you got when you set up Multi-factor Authentication.

0

I am able to open the Modern site in SharePoint designer with Owners Permission. If you have MFA enabled, you will get a different error which would day "Your account is in bad State". Please follow below steps and check if the error resolves.

Open the site over web browser

Open any document library in the explorer view

Then try to open SPD.

Also which version of SPD are you using?

0

I faced exactly this issue. No guarantee that this will fix your problem but it worked for me. Kudos goes to an MS tech who dug this up.

The problem lays with what sounds like a completely unrelated setting allowing custom scripts.

The fix involves a bit of work in PowerShell

First make sure that you have the Sharepoint Online Management Shell. You can get it here

Connect to your SP site. There are full instructions here but all you need to know is:

$adminUPN="<the full email address of a SharePoint administrator account, example: 
jdoe@contosotoycompany.onmicrosoft.com>"
$orgName="<name of your Office 365 organization, example: contosotoycompany>"
$userCredential = Get-Credential -UserName $adminUPN -Message "Type the password."
Connect-SPOService -Url https://$orgName-admin.sharepoint.com -Credential $userCredential

Provided that all works then use the command:

set-SPOsite "https://<ORGNAME>.sharepoint.com/sites/<SITENAME>" -DenyAddAndCustomizePages 0

That's all that it needed in my case. SharePoint Designer then worked perfectly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.