0

I have created a new team site inside sharepoint online. Then i defined the site to be Public + to allow external sharing as follow:-

enter image description here enter image description here

But when i wanted to share the site with existing external user (who have access to a classic team), i got this error message "could not add **** as member", as follow:-

enter image description here

so can anyone advice on this please?

Final note. note sure if it is related to my problem. But when i access the group (which got created automatically after creating the above team site), from the office 365 admin site, i got a message that i can not modify the group's properties due to permission (although i am sign-in as the office 365 admin):- enter image description here

1

This is by default that external users cannot be added as a member through the team site page.

You can go to Microsoft 365 admin center and select your group and then directly add a member. Then go back to your team site and refresh the page, new member will appear.

enter image description here

Also you can go to Outlook to add the member.

enter image description here

  • OK it worked for me from "Office 365 admin center" >> "Group", as you mentioned. where i was able to add external member. but in this case, we will be facing these 2 limitations. 1) the user who will be adding external user, need to be office 365 admin to be able to access the Group, so the team site owner will not be able to add external user unless his have office 365 admin permission. 2) second limitation , seems when adding users from the group itself, there is not any option to send an invitation email.. so is there any workaround to these limitations? – john Gu Sep 10 '18 at 14:54
  • this solution is still the accepted answer. Note, you'll need to be a Site Owner. Then, add user on outlook.office365.com, then confirm (or add again) user directly to the SP site. at that point, you can change permission to be read-only, if necessary. – 1c1cle Aug 28 at 16:44
-1

In the Admin center have you set your site collection to Allow Sharing?

enter image description here

That can be done on Admin Center > Site Collection > select your site collection > click on Sharing

  • i have already set this to "New & Existing external users" as shown in my question... – john Gu Sep 8 '18 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.