1

I have a team site collection inside my sharepoint online tenant, which i have migrated from sharepoint on-premises 2013. but i am a bit confused on how we can control if our pages library and our document library are rendered in Classic experience or in New experience.

  • On the tenant i defined the following:-

enter image description here

  • On all the document and pages libraries i have the following setting under Advance settings:-

enter image description here

Now the result i got inside my sites are:-

  1. If i access site home page /SitePages/Home.aspx,, which contain a web part for my document library,the home page it will be rendered in classic experience.:-

enter image description here

  1. while if i click on the document library itself /Shared Documents/Forms/AllItems.aspx it will be rendered in New experience :-

enter image description here

So not sure why the AllItems.aspx is being rendered in modern experience, while home.aspx is being rendered in classic experience..??

1

Unless there is some feature enabled on home page that is incompatible with the new UI. It auto-detects when there are unsupported features in place and automatically uses the classic experience even if the setting is for the new experience. Here's an article that details the unsupported features.

https://support.office.com/en-us/article/Differences-between-the-new-document-library-experience-and-classic-mode-30e1aab0-a5cc-4363-b7f2-09e2ae07d4dc?ui=en-US&rs=en-US&ad=US#BKMK_AutoDetectFeatures

  • thanks for the reply. but i have some home.aspx pages, which do not have any thing inside them, and i did not customize them,, but those migrated home.aspx are being rendered in classic mode.. – john Gu Mar 7 '18 at 12:14
1

Though you have set the default experience as new experience , it will not support for this Document App Part . The settings you have set is only for lists or libraries . You can only display these app part on a modern page .

https://support.office.com/en-us/article/use-the-document-library-web-part-a9dfecc3-2050-4528-9f00-2c5afc5731b0 .

  • thanks for the reply. now on the home.aspx i removed the document library web part, but still this home.aspx will be rendered in classic mode, regardless of the settings on the Pages library and on the tenant level... also i have other home.aspx page which did not have any web part inside it,, but still this home.aspx will be rendered in classic mode also.. not sure what is going on ??? – john Gu Mar 7 '18 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.