0

We have a SharePoint Designer 2013 Reusable Workflow which was working fine (at least, working fine in late 2017), but it won't start now. We get the alert standard message:

Sorry, something went wrong

But we don't have any additional information such as the correlation ID.

Searching in the logs, I found the following error:

Microsoft.Workflow.Client.WorkflowNotFoundException: 
    Workflow '71aad1c7-f0aa-41c0-8335-344fc3f1649d', for scope '/SharePoint/default/d67a99fe-0e4f-4fe7-8186-9163d92ee7ac/d65cf108-ca00-4bbf-aafa-501fd2971d7c', was not found. 
    HTTP headers received from the server - 
    ActivityId: b9ae995c-8215-4c63-bca4-42e6c6a76ad3. 
    NodeId: SERVERNAME. 
    Scope: /SharePoint/default/d67a99fe-0e4f-4fe7-8186-9163d92ee7ac/d65cf108-ca00-4bbf-aafa-501fd2971d7c. 
    Client ActivityId : 474d3d9e-4c70-502c-005f-be7e98ba1a7e.
        ---> System.Net.WebException: The remote server returned an error: (404) Not Found.     
            at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)
            at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)     
            at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)     
            --- End of inner exception stack trace ---     
            at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)     
            at Microsoft.Workflow.Client.WorkflowManager.StartInternal(String workflowName, WorkflowStartParameters startParameters)
            at Microsoft.SharePoint.WorkflowServices.FabricWorkflowManagementClient.StartInstance(String serviceGroupName, String workflowName, String monitoringParam, String activationKey, IDictionary`2 payload)
            at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflow(WorkflowSubscription subscription, IDictionary`2 payload) 
    StackTrace:  
        at Microsoft.Office.Server.Native.dll: (sig=9afccfd8-248d-4fb9-a01a-c8bacd6f7473|2|microsoft.office.server.native.pdb, offset=135DA) at Microsoft.Office.Server.Native.dll: (offset=21F8D)  474d3d9e-4c70-502c-005f-be7e98ba1a7e

While searching for this error, I saw this solution (Fixing Workflow Not Found Exception):

Again, these errors weren’t very descriptive. Through a bit of trial, error, and luck, I finally realized that the previously existing workflows were only deployed to the old Workflow Manager, which was no longer in use. Obviously the workflows would need to be redeployed for the new Workflow Manager. I then tried redeploying the workflows, and success! The workflows worked as expected

I tried to republish the workflow with SharePoint Designer, but the workflow still won't start.

Anyone has ideas of what could cause this?

Thanks.

  • Can you create a new workflow on a new list to isolate this issue if it is across whole SharePoint or just with that list? – Ahmad Zia Jan 5 '18 at 4:29
  • There is only one workflow affected. Other 2010 / 2013 workflows works fine. I'll try to create another workflow on this list and see the results. I can't do it now, but I'll get back with the result next monday. – Marc-André Jan 5 '18 at 17:53
  • Just tried out adding the the problematic list a brand new 2013 Reusable Workflow which logs some text, and it is working fine. – Marc-André Jan 8 '18 at 14:26
0

Try disabling the loopback check.

  1. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  2. Right-click Lsa, point to New, and then click DWORD Value.
  3. Type DisableLoopbackCheck, and then press Enter.
  4. Right-click DisableLoopbackCheck, and then click Modify.
  5. In the Value data box, type 1, and then click OK.
  6. Quit Registry Editor, and then restart your computer.

Created a new scope and register the workflow service with Register-SPWorkflowService, check if it works.

A similar issue: SharePoint 2013 Workflow Exception: Scope not found

0

After some tests, all other workflows on the site, even on the list itself, are working fine, so the issue had to be related to the workflow itself.

After simply removing the workflow from the list workflows and adding it back, the issue was resolved. To anyone else experiencing this, do not forget about things such as Custom Actions starting the workflow which you will have to associate again (There was only 2 custom actions for me, so not a big deal).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.