0

I cannot create new Designer Workflows (2013, very basic: create a workflow history entry).

What I tested so far:

  1. Okay to be honest: I can create new ones and they are correctly published and assigned to the list (according SharePoint Designer) but from the UI they are not available. enter image description here

  2. I exported a Workflow from another site and imported it. This worked fine without any issues, it will show up in the UI but it shows an error after trying to manually starting it. enter image description here

If I try to publish this workflow from the Designer, it disappears from the UI...

  1. After some search I found the following error in the ULS logs:

    Microsoft.Workflow.Client.InvalidRequestException: The scope '/SharePoint/default/b2ab4fc9-e61d-4eba-a8e0-1412d9fc30e4/6db43c86-9efe-49b3-b4a5-8e42a6920783' has no workflows under it. HTTP headers received from the server - ActivityId: 3fbeea12-858c-4ed4-a896-f48ed6182cb0. NodeId: VM-BIE-SP-PROD1. Scope: /SharePoint/default/b2ab4fc9-e61d-4eba-a8e0-1412d9fc30e4/6db43c86-9efe-49b3-b4a5-8e42a6920783. Client ActivityId : c4458d9e-d196-70be-3701-6bb329548336. ---> System.Net.WebException: The remote server returned an error: (400) Bad Request.

  2. After some more google-based-search, I tried the following things:

    • Flush DNS
    • Recycle workflow manager in the IIS
    • restarted Service Bus Gateway, SErvice Bus Message Broker, Workflow Manager Backend

Does anyone has another ideas / hints etc...?

  • I think I know about this issue. Off the top of my head I think it affects reusable workflows, you should be able to locate the workflow via the Sharepoint Designer menus. If you've not used Designer before, it is free Microsoft software. – Tally Sep 10 '18 at 9:46
  • I know the designer: it appears in the designer and I can publish it. But it will not show up in the UI to start the workflow manually. – Oskar Sep 10 '18 at 9:58
0

In a subsite created below the site collection the Workflows worked fine.

So I deactivated in the site collection the feature WorkflowServiceStore and activated it again - now it works fine :-)

  Disable-SPFeature -Identity WorkflowServiceStore –Url https://sharepoint.com -Confirm:$false
  Enable-SPFeature -Identity WorkflowServiceStore –Url https://sharepoint.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.