2

I have several instances of a SharePoint 2013 workflow calling a 2010 sub workflow. Let's say I have 'LibraryA' and 'LibraryB'.

Back in November of last year I started experiencing an issue with 2010 workflows in which I was using the 'Create List Item' action.

The workflow could not create the list item. Make sure the list exists and the user has permissions to add items to the list

At that point, I opened a support request with Microsoft, who tried to assist but offered little to no help, whatsoever. I also posted a question here: Previously posted question, but the only replies I got were related to On-Premise SharePoint rather than SharePoint online.

I had at that point come to the conclusion that simply recreating all the columns within the "Create List Item" action within the same workflow (completely identical!) solved the issue in all the cases. Also, I had noticed that after some time, say a week or two, the issue resolved by itself, and previously "corrupted" (and not yet fixed) workflows started working again. I had thought that this was perhaps a SharePoint Online bug that was fixed by an update.

Today I noticed that a 2010 workflow on a different library 'LibraryB', started returning the same error. I immediately tried:

  1. Recreating just the "Create List Item" action within the problematic workflow
  2. Recreating the workflow step by step including the "Create List Item" action

Both cases returned the same error, which means that while before, simply re-creating the action/workflow solved the issue, this time, this solution does not work.

This is restricting the client from working properly and even though I can go around it by implementing the List Item creation within CSOM (C#) and expose the method by an HTTP Web service, I would rather not go down that route, as there are many different instances and it would simply take too much time!

I found this link but it also seems to be referring to On-premise SharePoint: Go to Link.

Any pointers more specific to SPO would be much appreciated!

0

Granting full control permission to workflow solved my problem. This solution was provided by the Microsoft Office 365 support team after opening a support request.

Important: The procedure assumes the following:> The procedure must be completed by a user that has Site Owner permissions.> The workflow must already be published to the SharePoint site.

To grant full control permission to a workflow

  1. Click the Settings icon as shown in the figure.

  2. Go to Site Settings.

  3. In the Users and Permissions section, select Site app permissions.

  4. Copy the client section of the App Identifier. This is the identifier between the last "|" and the "@" sign, as shown in the figure.

  5. Navigate to the Grant permission to an app page. This must be done by browsing to the appinv.aspx page of the site.

Example: [http://%7bhostname%7d/%7bthe]http://{hostname}/{the Site Collection}/_layouts/15/appinv.aspx.

Note: The 'app' in this step refers to the Workflow app in general and not just a specific workflow. Individual workflows cannot be access controlled. When you enable app permissions you are enabling for all workflows within the Site Collection.

  1. Paste the client id in the App Id field and then click Lookup, as shown in the figure.

  2. Paste the following Permissions Request XML to grant full control permission.

    <AppPermissionRequests> <AppPermissionRequest Scope="https://domain.sharepoint.com/sites/NameofSiteColeection" Right="FullControl" /> </AppPermissionRequests>

Caution: There are no placeholders in the Scope value above. It is a literal value. Enter it exactly as it appears here.

  1. Click Create.

  2. You will then be asked to trust the Workflow app. Click Trust It.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.