I have an intermittent workflow issue that's proving exceptionally difficult to troubleshoot. Given the details below, what would be the next steps in finding a cause for this issue?


This is SharePoint 2013. The workflow was created in Designer 2013 and is using a 2010 template. It's a fairly simple workflow that creates a new list item, creates a matching document set in two separate libraries, then updates the list item with links to the document sets. The second step (creating the document sets) is an impersonation step that uses a service account. The service account is a site collection admin and also has full write access via policy on the web app.

Every great once in a while, the workflow will fail on creating the document set. The workflow status will be "The workflow could not create the list item. Make sure the list exists and the user has permissions to add items to the list." The outcome is "Unknown Error" and so far I've been unable to find any related entries in the ULS logs when this happens. I can live with this once in a while, but for one particular user it's happening a LOT. I've been tracking her workflows the past few weeks and it can happen anywhere from 25% of the time to 100% of the time. In other words, she'll have some days where she creates 20 list items and 1 fails. She'll have other days where she creates 20 list items and 19 fail - it seems completely random & intermittent.

When the issue happens, deleting the list item and creating it again (to trigger the workflow) usually works. Sometimes it doesn't. This issue only seems to affect this one user. The workflow completes normally 99% of the time for myself and everyone else.

Here are the steps I've taken so far to troubleshoot:

  • Made her a site collection admin. Same issue.
  • Confirmed that she has write access to both the task & history lists used by the workflow.
  • Put a 5-min pause between each step in the workflow. Same issue.
  • Put the document set creation part in its own separate workflow. Same issue.
  • Had her log in as herself on someone else's computer and try. Same issue.
  • Changed the workflow to use her own credentials instead of the service account. Same issue.
  • Deleted the user from the site collection and set up her permissions from scratch again, then had her try. Same issue.

Also, to give you an idea of how random this is - when I had her login on someone else's computer and try, here's how it went down:

  1. Tried on her computer. Workflow failed.
  2. Tried on the other computer. Workflow failed.
  3. Tried a 3rd time back on her computer. Workflow completed normally.

Say what? Exact same name & field values on the list item, and I confirmed that she's doing everything exactly as I would. Yet it fails 2 out of 3 times for her.

Any suggestions are appreciated - I'm just not sure where to go with this one.

UPDATE: We never did find a resolution to this, even after removing her from the site collection and re-adding her. As it happens, someone else took over the role (previous user was temp) and the new person isn't experiencing the issue. So case closed, I guess.

  • You could try removing her AD user account and recreating her... the next logical evolution of 'did you restart it' -- but I should stress this won't really be a good answer (it is rather extreme, plus you would have issues with other services like mail), it just might work given the other things you've tried!
    – John-M
    Aug 19, 2014 at 19:18
  • Try to remove her from site collection, and add again. You can try to test with Impersonation Steps in workflow too. Aug 20, 2014 at 14:08

4 Answers 4


I just had this same issue and figured out what was causing it in my case. I had a list that triggered a workflow to create a folder in a document library based on the list item's Title. The user that kept having the issue was copying and pasting the titles. This was occasionally causing a space at the end of the title. I'm not sure exactly why it caused the workflow to fail, but my guess would be that it was trying to convert that space into a special character. I'm going to work on some validation to not allow a space at the end.

  • 1
    I've run into that issue as well. I added some jQuery behind the New Item form that replaces trailing spaces, double-spaces, periods, etc. SharePoint can be pretty quirky when it comes to stuff like that.
    – Omegacron
    Jun 5, 2015 at 13:57

You might make sure the string you are using to populate the "Path & Name" for the document/item does not contain any invalid characters. I was getting this error, and after a day of troubleshooting figured out it was an apostrophe in the string that I used to create the variable which served as the Path & Name of the target document.


I had a similar issue. I have a workflow for a list that creates a document set (folder) when user triggers the workflow. Sometimes the workflow failed, I looked at the data and noticed a common variable when the workflow failed. When users entered special characters (ampersand &, forward slash/, or colon:) in the field (Title), the workflow would failed.

Solution: cancelled workflow (Failed on Start) , removed special characters in the field and restarted workflow.

Although this is a workaround, have not figured out how to prevent users from adding special characters to the title field.

  • Yes, I've seen that as well, although it wasn't occurring in this case. As for preventing the special characters, I put a jQuery script behind the form that strips out the dozen or so most common ones.
    – Omegacron
    Jul 27, 2018 at 18:22
  • @Omegacron, I tested the different characters (~ & ! @ # $ % * + : [ ] / \ ) and found that these were causing the workflow to fail: ampersand #, asterisk *, colon :, and forward slash /. The other workflow were fine, so piggybacking from this site I added the validation to the field: collab365.community/forum/topics/…
    – avastardis
    Jul 27, 2018 at 20:43

I had the similar issue with workflow failing to create list item. Following steps resolved this for me.

If you are creating an item in the library that allows several content types, make sure that the new item's content type has a template associated with it.

To do that, create an item manually using UI, from SP designer, go to the library, select the item and then export it. Then go to library content types, select the target content type, go to advance settings and select Upload a new document template.

Once I assigned the document template, SPD workflow created the item successfully. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.