2

i defined my properties in display template, this is the generated javascript

ctx['DisplayTemplateData']['ManagedPropertyMapping']={'Title':['Title'], 'Path':['Path'], 'Description':['Description'], 'EditorOWSUSER':['EditorOWSUSER'], 'LastModifiedTime':['LastModifiedTime'], 'CollapsingStatus':['CollapsingStatus'], 'DocId':['DocId'], 'HitHighlightedSummary':['HitHighlightedSummary'], 'HitHighlightedProperties':['HitHighlightedProperties'], 'FileExtension':['FileExtension'], 'ViewsLifeTime':['ViewsLifeTime'], 'ParentLink':['ParentLink'], 'FileType':['FileType'], 'IsContainer':['IsContainer'], 'SecondaryFileExtension':['SecondaryFileExtension'], 'DisplayAuthor':['DisplayAuthor'], 'ServerRedirectedURL':['ServerRedirectedURL'], 'SectionNames':['SectionNames'], 'SectionIndexes':['SectionIndexes'], 'ServerRedirectedEmbedURL':['ServerRedirectedEmbedURL'], 'ServerRedirectedPreviewURL':['ServerRedirectedPreviewURL'], 'RefinableString06':['RefinableString06'], 'UIVersionStringOWSTEXT':['UIVersionStringOWSTEXT'], 'RefinableString04':['RefinableString04'], 'RefinableString03':['RefinableString03'], 'RefinableString01':['RefinableString01'], 'RefinableDate00':['RefinableDate00']};

Then i used SearchQueryToolv2.5 to see whether result for item i'm debugging javascript on actually have crawled/managed properties like RefinableDate00 ... and it does.

When i display properties of ctx.CurrentItem in chrome javascript debug I see that there are my defined properties, but all are empty.

I also refreshed Result Types page both in site collection administration and site administration for site where i use search and display templates.

I'm think it worked before and just stopped, as I don't see why I would put something that does not work to the production enviroment.

How to get it working?

1

Go to SharePoint admin center > search > Manage Search Schema > Managed Properties, then click property name to view the details. In the Main characteristics section, make sure Searchable, Query-able, Retrievable are checked.

Also make sure your custom properties has been mapped to a managed property.

enter image description here


Also make sure after you have the right configuration, the properties has been crawled.

To request your tenant to instantly reindex e.g. a list, do the following:

  • On the site, go to the list or library that you want to re-index.

  • In the ribbon, click the Library tab or the List tab.

  • In the Library ribbon, choose Library Settings, or,

  • In the List ribbon choose List Settings.

  • On the Settings page, under General Settings, choose Advanced settings.

  • Scroll down to Reindex Document Library or Reindex List, and click the button. The content will be re-indexed during the next scheduled crawl.

I hope that gives you some help!

  • That is 100% NOT the issue as i already verified that the properties are crawled and indexed, and I even can use them in refiners. – Evlo Jan 11 '17 at 10:27
  • @Evlo Ok, too bad that didnt help, I don't know what's causing the issue then. hope you find the cause... – Leif Walder Jan 11 '17 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.