0

Environment : Sharepoint 2010

I have a workflow on a list that sends a task to a user. The form of this task is not compatible with any browser. Also by mail, it's impossible to open it.

I have these errors when I open the task :

  • with Chrome : "This form cannot be opened in the browser. To open this form, use Microsoft InfoPath."

  • with Internet Explorer : "The specified form template could not be found, or is not compatible with rendering in the browser. It might need to be republished as a browser-enabled form."

  • with Outlook : "Outlook cannot open a new form, the form contains schema validation errors."

What I did to get that :

I've just added a field in the task directly in the workflow (using the data collect command). The task was already here and worked well before that.

When I did the change, my workflow ask me to update the task form with InfoPath (I just never had to do stuff with InfoPath). If i hadn't done that, I couldn't have publish my workflow. Then I did that. And since, there's a problem with the opening of the task form on any browser.

Any solution ?

0

Ok, I fixed it.

It's as simple as that : In SharePoint Designer, on my workflow page, I just deleted my form from the form block (see below). And when I have published my workflow, my form was recreated but it works everywhere.

enter image description here

  • To delete it, just select it, and in the ribbon you can click on the delete button.

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.