5

I want to create new document set in my document library. But there is no option to create Document Sets

I just have option to create new document

enter image description here

I already enable document sets features and enable content type management in Library Settings -> Advance Settings. But still there is no Create Document Set option

7

Please verify below things

  • Go to site setting and features and make sure that the DocumentSet Feature is activated.
  • Go to library setting and navigate to Advance setting and make sure that Allow Managed Content Type is set to true.
  • Go to list settings and then assign Document Set content type to the library.

As per your question it seems that you missed the last option. Assigning Document Set Content type to library.

4

Go back to Library Settings > Advanced and check "Allow management of Contemt types" and save. Back in Library Settings you can scroll down to Content Types and add a default Document Set Content Type (or a custom one). When you see the Document Set among Content Types in Library Settings - you will also see Document Set in the New button.

1

Make sure once you activate the feature at site collection level you do the below things

  1. Enable allow management of content types in advanced settings in your document library
  2. Click on add from existing Site content types
  3. Select document content type and below you will find the list of document content type and select Document Set and click on Ok

now should be able to see the document set template available

1

So there were good answers posted already and only some screenshots were missing for those who tend to get lost in SharePoint UI :)

To be able to create document sets within SharePoint libraries you have to:

1) Allow management of content types in Advanced Settings of this library:

enter image description here

2) Add Document Site content type using “Add from existing site content types” link in library settings:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.