1

Currently I have a document set that has numerous content types in it. However, 7 new content types that I added to Document Set Settings aren't showing in the library when I click to create a new document and the content type drop-down list appears.

I am aware of the crawl time, but it doesn't make a difference. I have already tried removing and re-adding the content types from the document set settings, but this didn't work.

What is the reason for these 7 content types not being available in the library and is there a way to fix it?

0

Here are steps to get see the newly added content types in the Document Set Settings.

1: Current Content Types on my Document Set

enter image description here

2: Added a new content type from the Document Set Settings

3: I see a notification on my Document Set Welcome Page enter image description here

**4. I click on the "Update the Document Set and then I see my newly added Content Type"enter image description here

  • I'm using SharePoint 2013, although this process is a bit different, I already used this solution and it didn't work. My steps included adding the Content Types in the Document Set Settings, "Publish" my changes (the same as "Update the Document Set" I presume), waiting for the crawl time (overnight even), but nothing changed in the Library to which the changes are supposed to occur. – Soni Jun 16 '17 at 12:34
  • I think you are trying to make changes to the Document Set Content Type in the Content Type Hub and publishing those changes. As per my knowledge Content Type Hub to publish the custom content types, not for OOB content types. – Venkat Konjeti Jun 16 '17 at 13:09
  • Check the content type service application logs. – Venkat Konjeti Jun 16 '17 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.