5

My list X has unique permissions. Group A has contribute and approve permission on this list, but only read permissions to the whole site. However, when group A tries to launch a workflow manually in list X (via Files -> Workflows) it says: "Sorry, this site hasn't been shared with you."

Giving them full control on the list did not solve the problem, but full control on the whole site worked. So I assume that I have to give group A give permissions somewhere else on the site to allow them to launch workflows. But where would it be?

With SP Designer I found the Document Library "Workflows". I gave group A full control to this library, but it didn't solve my problem.

"Sorry, this site hasn't been shared with you" appears after clicking this button! picture of workflow button

For future readers: As stated in an old question (linked in the answer below), the behaviour is by design. A user at least needs to have contribute permissions on the site level, in order to launch workflows manually.

  • Is the workflow using any data from other list/library? – Gintas K Jul 26 '16 at 12:14
  • No. But the error occurs even before selecting one specific workflow. It occurs once the user clicks on the general Workflows button. – wheeler Jul 26 '16 at 12:24
  • What does the workflow do on triggering it? – Nagarajan Muthukumar Aug 1 '16 at 11:40
  • The workflows do nothing. They can not get started by the user, because the user can not access them. It's not a problem with a specific workflow. – wheeler Aug 1 '16 at 11:48
  • have you tried to clear SP designer's cache after changing the permission? You also need to provide the contribute permissions all related lists like Tasks Lists, History Lists etc. Please validate if you have any hidden list as well. – Vikas Sharma Aug 1 '16 at 12:27
8
+50

Try to share the Root SharePoint Site to Group A

  • As Limited Access to Can view specific lists, document libraries, list items, folders, or documents when given permissions.
  • And as contribute to the SharePoint list that has the workflow with its related Task List and History list.

You may also need to check "How to elevate Workflow permissions in SharePoint 2013" by doing the following :

  • Allow workflow to use app permissions.
  • Grant full control permission to a workflow.
  • Develop the workflow to wrap actions inside an App Step using SharePoint Designer.

For more details about How to apply the above steps check The Workflow was Suspended with Unauthorized HTTP / elevate Workflow permissions in SharePoint 2013

Update :

  • The behaviour is by design. A user at least needs to have contributed permissions on the root site, in order to launch workflows manually as mention at this thread Manually start SharePoint 2010/2013 workflow in SharePoint 2013 farm?

  • Also, check the latest CU that has been installed , it's preferred to apply Service Pack 1 if it's not applied where maybe this issue solved at it. hope it helped you

  • But my problem is not that a specific workflow cannot get started or throws an error. My problem is that some users can't access the site, on which they could select which workflow shall run on an item. – wheeler Jul 26 '16 at 12:49
  • Follow up on your edit: The group already has read permissions (+ limited access) to the root site. Contribute to the Task List and History List did not help (see comment section). – wheeler Aug 2 '16 at 11:22
  • Ok let's try to investigate this issue , are this issue occurred for all associated list workflow or only this workflow ! – Mohamed El-Qassas MVP Aug 2 '16 at 11:25
  • Workflows that are started on creation or on edit work fine. But any workflow that shall be launched manually by the user, cannot be started, because the group can't access the workflow overview of one item. – wheeler Aug 2 '16 at 11:47
  • 1
    For future readers: As in the old question linked in the answer, the behaviour is by design. A user at least needs to have contribute permissions on the site level, in order to launch workflows manually. – wheeler Aug 2 '16 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.