0

I have a document lib and i have added a custom " Permission Levels " to it. The permissions allow users to only add,delete ,view but NO EDIT

The problem i have though is when i login has the restricted user and upload a document and then go to the forms to be able to fill it in...

Then i get error:Sorry, this site hasn't been shared with you

Any ideas why this is happening/

  • How did you give the permission, Did you assign any group ? Have you created your custom permission level for add, delete, view, not edit ? – Ronak Patel Jun 21 '16 at 4:11
  • When you upload a document first document get's uploaded to the library then you get edit forms to edit the properties. Since you haven't edit rights on the library so you are getting this error. – Amit Jun 21 '16 at 5:18
  • Thanks Ronak for the response.I did create the custom permission and used it with a group. – naijacoder Jun 21 '16 at 5:39
  • Thanks Amit for the reply. So are you saying it cant be done. When I select edit on my custom permission it works. Any workarounds for this? – naijacoder Jun 21 '16 at 5:41
2

In SharePoint, when we upload a document to a library, the document will be uploaded to the library first and then it will pop up the document properties form for us to fill in the values.

However, only a user who has edit items permission on the library can edit the document properties, so the form popped up for filling after uploading the document will show access denied if a user does not have edit item permission, but the document is uploaded successfully.

It acts different between adding a new item in a library and in a list.

And I recommend to give users edit item permission on the library if you want users to be able to fill in the properties for documents.

  • Thanks Amit. Don't want them to modify a particular field – naijacoder Jun 21 '16 at 7:07
  • Are you using SharePoint on prem? – Amit Jun 21 '16 at 10:49
0

This is expected behavior since you removed edit items role from your custom permission level. Since you have metadata attached to your library, when uploading, it will redirect the user to the EditForm.aspx page so the user can supply the necessary metadata fields. Since you removed this role, you get the error screen.

Some ways to resolve this:

Give the users back edit items role. Using the advanced settings of the library, enable the management of content types and mark your field you don't want them to change to hidden. This will remove it from forms.

If that isn't suitable, create a folder structure where users can upload documents to. Using the column value default values option, set the desired metadata fields on the folders. When a user uploads a file to that folder, it will get the metadata values you defined.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.