3

I have an InfoPath form with a file attachment button but when a user tries to upload an attachment(clicks on the button)nothing happens. When I click the same button a dialog box to browse for a file to upload comes up. Is this a permission issue? I've granted her full control to the site/list but it is still not working. Any ideas?

  • Are you and the user using the same web browser, the same version of browser? Have you checked if either you or the user is running the InfoPath form in compatibility mode assuming you are using IE? – Mihail Popa Dec 17 '15 at 16:46
  • How do I check for compatibility mode? – R Hilton Dec 18 '15 at 12:47
  • The compatibility mode is available in Internet Explorer browsers only. To access the compatibility settings, you go to Menu bar > Tools > Compatibility View Settings. In the window that pops up check that you and the user have the same settings. – Mihail Popa Dec 18 '15 at 12:52
  • Hi Mihail, thank you so much for your help. Am I looking for the browser tools or tools in SharePoint? Sorry, I'm really new at this. – R Hilton Dec 18 '15 at 12:55
  • 1
    If the user experiences the same issue on your machine, then it is definitely a permission issue. I presume the InfoPath form is attached to a SharePoint list of some sort. Make sure the user has at least Contribute permission to the list. In the case the InfoPath form stores the files uploaded in a specific library, then make sure the user has Contribute permission to that library. – Mihail Popa Dec 18 '15 at 13:08
1

This is an issue with InfoPath and SharePoint permissions.

When you use the attachment control on a SharePoint list that has been customised to use an InfoPath form, the attachment control behaves differently than to the default out-of-the-box SharePoint list form..

The user needs both "Add New Item" & "Edit Item" Permissions to use the Attachments control on an InfoPath customised SharePoint list form.

These permissions are not enough to allow SharePoint list Attachments with a customised InfoPath form (but are enough for a default SharePoint list with no InfoPath customisations):

No Edit

These permissions will allow SharePoint list Attachments with a customised InfoPath form:

Yes Edit

This is really frustrating, as if you do not use an InfoPath form, the list Attachment is readily available (albeit in the ribbon) for users that only have "Add New Item" permissions, and not "Edit Item" permissions.

Ribbon for InfoPath Form customised list:

Form Customised Ribbon

Ribbon for default SharePoint list form with no InfoPath customisations:

SharePoint Default Ribbon

(Side note, unrelated to this question)

I ran into this issue recently when I created an InfoPath form for users whom I did not want to be able to edit their submissions after posting an item.

I got around this issue by granting the user "Edit Item" permissions, and then creating a Content Type that used another InfoPath form with read only fields, and switching to this content type with a SharePoint Designer Workflow that ran on item creation. This effectively made any edit attempts useless.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.