8

I am attempting to create a SharePoint 2010 workflow in a SharePoint 2013 instance that moves a document from one library to another if a certain field in the meta-data is set to "No". Given that there is no Move Item action available I elected to copy the item to the library if the criteria is met and then delete the Current Item from the list that initiated the workflow. All of this works fine if the List is set not to require check-out. If the list is set to require check-out to edit the document then the copy action succeeds but the delete action get's cancelled with the following message: enter image description here Stating that the workflow was cancelled because the action required that the document be checked out. So I inserted a Check-out document action into the workflow in every scenario that I could think of. Before the Copy action, between the copy action and the delete action. I also included the corresponding Check-In action. No matter what scenario I tried I get the same result. The copy works but the delete does not.

The first two questions I have are: Why there is no "Move" action? And why am I getting this error when clearly the copy action is succeeding and it's the delete action that is failing? Of course, neither of these can truly be answered here.

The real question is why would the delete action not complete successfully?

I am using SharePoint Designer 2013 against a SharePoint 2013 Online environment.

Here is the entire workflow as I last tried it:

enter image description here


Update: I tried putting the workflow into an Impersonation Step to see if this may have been caused by a permissions issue. I got exactly the same results.

Update 2: It appears that it is the Copy action that is throwing the error. I am trying a different (more complicated) approach. I am having the second library delete the source object in the initiating library with another workflow. In doing so I removed the Delete action from the initiating workflow but it still throws the same error. That the copy action failed . . . even though it actually succeeds.

I guess the only real question is:

  • Why would the copy action throw an error when the action was successful?

Update 3: Since this is no longer the actual question associated with the title of this post I have decided to close this question and add another with the real question that came out of my research.

0

I turns out that the issue was not with the Delete action but truly was the Copy action throwing an error even though it succeeded in copying the document. I have added another question to handle that error.

SharePoint 2010 Workflow Copy Item Action Succeeds but Throws Error

  • Your link no longer exists. Can you post your resolution here? – AtariPixel May 28 '18 at 11:03
0

It seems that once this error is thrown in the workflow, it will not continue on and delete the item. I thought the error was suggesting I needed to check out the item in the origin Document Library. My issue was resolved by turning off Check In/Check Out in the destination Document Library.

I'm not sure there is a way to keep Check In/Check Out enabled in the Destination Library and still have this action work. I also tried checking out the document before copying but, still get the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.