2

I have a Document Library with the following Settings: -

Require content approval for submitted items= Yes Require documents to be checked out before they can be edited=No

I have a SPD approval workflow acting on a document library. Everything works but I am now required that the user is forced to check-out the document.

I now set the document library to :

Require content approval for submitted items= Yes Require documents to be checked out before they can be edited=Yes

The workflow fails due to requiring the document to be checked-out. So I add the following actions within the workflow

'Checkout item in current item' and 'Set Content Approval status to Approved' Actions in the workflow

Now workflow checks out document, but a different error occurs. workflow history shows :User Id System Account, Event type - Error

The workflow could not update the item, possibly because one or more columns for the item require a different type of information.

I've looked for soltions but cant find any answers. Any help appreciated, using 2010 with latest CU.

I've added actions to 'When a Task Completes'

enter image description here

2
  • i have same issue and looking for answer and/or work around
    – user14390
    Jan 24, 2013 at 19:13
  • Did you manage to do it finally? what were the steps? Or did you hit Catch-22? May 27, 2014 at 7:58

3 Answers 3

1

If by "add Checkout" you mean that you added a new Outcome than you should know that is not a acceptable value for the Content Approval status which only accepts Approved, Rejected, or Pending.

Check-Out is an automatic state, but is unrelated to Approval of content.

2
  • I've updated my Original question to be more accurate. I dont maen a new Outcome. Any ieas ? Jan 14, 2013 at 8:41
  • I suspect that the action "Set Content Approval" status already checks-in the document for you. Jan 14, 2013 at 13:05
0

This is something I've been working on for several hours and finally got it.

The only way that I have found is to go into your settings for the folder, go to "versioning setting," and where it says "Require content approval for submitted items" select "no."

0

To do this you need to put the "change content approval status" step to AFTER the check-in, not while it's checked out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.