1

I am new to SP 2013; however, I have completed setup of a three-tier server farm (SP2013, Database and OWA Servers). My problem now is specifically related to the SharePoint Store, as I receive the message:

Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

Here's what I have done so far:

Apps Domain Setup:

  1. New forward lookup zone = contosoapps.com
  2. Alias = *
  3. FQDN = contosoapps.com
  4. Host FQDN = sharepoint1.contoso.local
  5. I can successfully ping anything.contosoapps.com and it resolves to the IP for sharepoint1.contoso.local

Via Powershell:

  1. $acct = GetSPManagedAccount "contoso\spServices"

  2. $apppool = New-SPServiceApplicationPool -Name SubscriptionAppPool - Account $acct

  3. $app = New-SPSubscriptionSettingsServiceApplication - ApplicationPool $apppool -Name SubscriptionSettingSvcApp -DatabaseServer SP-SQL -DatabaseName SubscriptionSetting_Service_DB

  4. $proxy = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $app

Central Admin: Configure App URLs

  1. App Domain = contosoapps.com

  2. App Prefix = app

Central Admin: Manage App Catalog > Create New Catalog Site

  1. Site URL = http://sharepoint1/sites/AppCatalog

  2. Site Collection Admin = contoso\spadmin

  3. Users/Groups = NT Authority\Authenticated Users

Central Admin: Configure Store Settings

  1. App Purchases = Yes

  2. Apps for Office from the Store = No


When I go to "Add an App", then "SharePoint Store", I get this message: Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

In Central Admin, when I go to Manage Service Applications,

  1. App Management Service Application is STARTED

  2. App Management Service Application Proxy is STOPPED

  3. All other required services seem to be running, from what I can tell.

Could this have something to do with it? If so, do I need to start this service from PowerShell? I don't see a way to start it from within Central Admin. As I stated earlier, I am new to SP as well as PS!

Thanks in advance for any assistance provided!

  • Make sure your webapplication is connected to the App Management Service Application Proxy – Amal Hashim Jan 27 '15 at 22:46
  • Thanks for the response, Amal. As I mentioned before, I am still very new to this. How would one go about connecting the web application to the App Management Service Application Proxy? – Dave Kox Jan 28 '15 at 15:41
  • Thanks again, Amal. I just happened to find that same article prior to your response. The web application was already connected to the App Management Service Application Proxy. Any other ideas?? – Dave Kox Jan 28 '15 at 16:55
0

As posted here and here, you could try opening the SharePoint 2013 Management Shell and running these cmdlets:

$sap = Get-SPServiceApplicationProxy | where-object {$_.TypeName -eq “App Management Service Application Proxy”}
$sap.Provision()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.