1

I have a single server development environment. I do not have DNS. I have IIS and host file.

I would like to install an app on my development environment. It still would not work. I got this error when I try to add the app to a site collection.

SPException thrown: Message: The App domain for this site has already been assigned.. Stack:   
 at Microsoft.SharePoint.Utilities.SPUtility.ThrowSPExceptionWithTraceTag(UInt32 tagId, ULSCat traceCategory, String resourceId, Object[] resourceArgs)    
 at Microsoft.SharePoint.Administration.SPConfigurationDatabase.EnsureAppSiteDomainPrefix(Guid id, String subscriptionName, Boolean overwrite, String appSiteDomainIdToUse, String& newAppSiteDomainId, List`1& siteUrls)    
 at Microsoft.SharePoint.SPSite.EnsureAppSiteDomainPrefix(Boolean overwrite)    
 at Microsoft.SharePoint.Packaging.SPUserCodeSolutionDeploymentGroup.Deploy()    
 at Microsoft.SharePoint.Administration.SPAppTask.DeployOperation()    
 at Microsoft.SharePoint.Lifecycle.MonitoredTaskExecution.DoTask()    
 at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)    
 at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)    
 at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)    
 at System.Threading.ThreadHelper.ThreadStart()

I did already this configuration:

  1. I go to central admin
  2. I click on apps
  3. I click on app catalog
  4. I selected some webapplication
  5. I created a new app catalog "http://myCompany.com/sites/MyAppCatalog
  6. I did created the subscription service application with powershell
  7. I set the "Configure App URLs" as follow: domain: appsMyCompany.com, prefix: app.
  8. I set this domain "appsMyCompany.com" in the host file.
  9. I created a new webapplication with the url: appsMyCompany.com

UPDATE

When I add the app as an instance in the app catalog (on Site Contents page), it is working. When I click on the app I get an 404 error. This is because the subdomain which the app instance is using is not exist in IIS. (http://app-04ab54ab4d69a7.appsMyCompany.com/sites/MyAppCatalog/AppCompanyAdvancedAnalytics/Pages/Default.aspx?SPHostUrl=http......some stuff)

Do I need to add some wildcard binding to the webapplication appsMyCompany.com ? Or do I need to add a binding with the url app-04ab54ab4d69a7.appsMyCompany.com to the webapplication appsMyCompany.com.

  • what you enter in the host file app.appsbrabantwater.nl or appsbrabantwater.nl? – Waqas Sarwar MVP Jun 4 '15 at 14:52
  • I add appsMyCompany.com. See also my update. – Ola Jun 4 '15 at 15:31
  • did you added that url in AAM as well? check this ashokraja.me/post/… – Waqas Sarwar MVP Jun 4 '15 at 16:27
  • It is still not working. Also with the url in AAM. – Ola Jun 8 '15 at 9:15
  • 1
    IT works! I have created a new webapplication for the app domain. In iis I add the wildcard character (*). In the host file I add the app domain url, but also the url of the app instance: app-04ab54ab4d69a7.appsMyCompany.com. – Ola Jun 8 '15 at 12:00
1

As You Dont have the DNS then you need to add the host file entry.Add your App domain in the host file.

  • Add the "appsMyCompany.com" into host file.
  • Disable the loopbackcheck on server
  • Add the apps url into web application's AAM settings.
  • Edit the IIS Bindings

Please read complete step over here.Develop SharePoint 2013 Napa App In Local Dev Environment (Configuring On Premises without DNS)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.