I am unable to load infopath form and this new SP 2013 farm does have State Service and proxy setup. Also, made sure it's association. All looks good. Are there any harm undo the current State Service App and re-do? I even ran the config wizard from Central Admin but no luck.

If I need to undo the current state service app how would I go by doing that. Would it hurt the workflow and other SP features.

Here is the error:

The form cannot be rendered. This may be due to a misconfiguration of the Microsoft SharePoint Server State Service. For more information, contact your server administrator.

It will not hurt the current settings, simple delete it and redo using the powershell.

$stateName = “State Service”
$stateDBName = “SP2013_State_Service”
$stateDB = New-SPStateServiceDatabase -Name $stateDBName
$state = New-SPStateServiceApplication -Name $stateName -Database $stateDB
New-SPStateServiceApplicationProxy -Name “$stateName Proxy” -ServiceApplication $state –DefaultProxyGroup

When you have successfully configured the State Service you will see this in your powershell window:enter image description here

InfoPath 2013: Misconfiguration of the State Service

| improve this answer | |
  • Thanks for confirming and providing the script. 1. I deleted the app. 2. Ran the script 3. Re-created a list 4. Edit the form in InfoPath 5. Save the form 6. Now it's working. Thanks – Kevin Short Jun 10 '15 at 20:15
  • Well done, it helps! – Gennady G Jun 29 '16 at 20:20

Check the database status of State Service and re-enable the state service by using one of the following approach.

  • Through PowerShell script:

    New-SPStateServiceDatabase -Name "StateServiceDB" -DatabaseServer "DBServerName" | New-SPStateServiceApplication -Name "State Service" | New-SPStateServiceApplicationProxy -Name "State Service Proxy" -DefaultProxyGroup > $null

  • Below are the steps to activate the “State Service” from Central Administration site:

  • Launch the “Farm Configuration Wizard”


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.