0

I have created a new web application inside my SharePoint 2013 on-premises. Then I created a new app catalog for my new web application. now I went to the app catalog and I add a new .app file as following:

enter image description here

Then I went to a site collection inside my new web application >> Add App >> from your organization >> I select the new app. But I got this error:

Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.

As followingly:

enter image description here

So can anyone advice on this please? Thanks.

  • 1
    Did you setup APP environment? – Venkat Konjeti Jun 20 '17 at 15:31
  • @VenkatKonjeti the way i understand things is that App environment have to do with creating the app catalog site for my web application is this correct? – john Gu Jun 20 '17 at 16:21
  • 1
    Creating an App Catalog site is only one step in the complete App environment setup process. Can you look at my answer below and verify that you have completed all steps mentioned in the MSDN article. – Venkat Konjeti Jun 20 '17 at 16:34
  • 1
    We do follow this technet.microsoft.com/en-us/library/fp161236.aspx. The second link is just for reference to point the same issue. – Venkat Konjeti Jun 20 '17 at 20:14
  • 1
    Let us continue this discussion in chat. – Venkat Konjeti Jun 21 '17 at 12:52
1

To work with APPs in SharePoint on-premises server you have to follow below steps.

Below are steps to work with apps on your farm

  1. Configure the domain
  2. Configure SSL certificate settings (if your site is running on https protocol)
  3. Configure APP services.

MSDN article on setup APP environment

How do I turn on SharePoint App store in SharePoint 2013

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.