13

It seems like I can't modify a private view to be public, or duplicate a private view to be public.

Am I restricted to copying by hand all the settings of my private view, then creating a fresh public view and selecting all the right columns in the same order with all the sort and filter options?

1
  • @bkwdesign After clicking the Enter 2nd time, it shows 'False' in POP-up message. However, when i click ok then it shows error. "Error Cannot complete this action. Please try again" Please help
    – CKS
    Jun 9 '20 at 7:30
25

There are no direct options available in Sharepoint. It seems to be a bug in SharePoint and they have forgotten to enable that radio button. Here is an alternative approach:

  1. Click on Create View
  2. Select your private view
  3. Use either 'Developer Tool' if you are using IE or 'Firebug' if you are using Firefox. Enable this tool and then locate the second radion button.
  4. Remove the attribute 'disabled' from the radion button
  5. Add a new attribute 'checked="checked"' to the radio button.
  6. Now save you view and you are done.
6
  • This worked perfect! I was afraid that I would have to start all over.
    – AxGryndr
    Jun 9 '14 at 21:00
  • Great hack!!! very useful.
    – Tabares
    Nov 11 '14 at 22:04
  • It's a shame my reputation points don't rollover to here, or I would up vote this issue. It's a really great hack! It makes you wonder why Microsoft doesn't just enable the control.
    – W.W.
    Feb 6 '15 at 21:42
  • At first I thought I needed to change the value="FALSE" to true. But evidently that breaks it. If I had only followed the directions the first time! :)
    – Rothrock
    Jun 18 '15 at 20:49
  • Perfect little hack. Worked perfectly thank you, more people should know about this, there are dozens of pages saying this can be done.
    – user51496
    Feb 19 '16 at 9:48
1

There is no other way but to create the view manually again.

You cannot change a personal view to a public view or a public view to a personal view. You can use a public view as the starting point for personal or public views. You can use a personal view as the starting point only for personal views.

SOURCE

0

@Manz's answer does not seem to apply to my SharePoint Foundation 2010 installation. I think @Nadeem's answer may apply to me.

The following answer DOES NOT CURRENTLY WORK but was my best attempt to get it to work in SPF 2010. Maybe someone else can expand upon this and get it to work.

I can see in my source code that there's no actual radio button exposed. The HTML is so quirksmode-ish that my IE Developer tools fails to even show it in the DOM even though it's in the source. Thus, if your SharePoint output only renders an <input type="hidden" name="Personal" id="PersonalView0" value="TRUE"></input>, you might want play with adapting this route:

  1. Go to your private view, hit "Modify View"
  2. Paste this javascript as-is into your browser's address bar: javascript:alert(document.getElementById('PersonalView0').value);
    • WATCH OUT - YOUR BROWSER WILL TRY TO HIDE THE javascript: PROTOCOL WHEN YOU PASTE - FIX THIS AFTER YOU PASTE, BEFORE YOU HIT ENTER
  3. Press ENTER and you should see the word "TRUE" pop-up in a message box (I like to do this step to simply verify the field exists)
  4. Paste this javascript into the address bar (and press ENTER) to actually change the hidden input's value AND verify that it changed: javascript:document.getElementById('PersonalView0').value="FALSE";alert(document.getElementById('PersonalView0').value);
    • WATCH OUT - YOUR BROWSER WILL TRY TO HIDE THE PROTOCOL WHEN YOU PASTE - FIX THIS AFTER YOU PASTE, BEFORE YOU HIT ENTER
  5. Now press the 'Edit View' page's OK button to submit the form
0

As written, this did not work for me. When I saved, the view was still a Personal View.

However, my work around was to simply delete the disabled="" attribute. Then, use the form to select Public View.

When I saved the new view, it was Public, even though I had started from a Private view.

0
0

I found quite the elegant workaround that doesn't have you going into Developer mode or any changing of settings. (Especially if you don't have those permissions to begin with).

For some reason you can do the following if it's a private view. Just go into edit more for the view and select "Make Default View" this will force the private view to become public since only public views can be default. Click on "Save". Now go and set your original Default view back to the default, and your once private view is now public.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.