I have a list named "Test".

On this list I enabled approval workflow named "Test".

If you take a look at screenshot below which shows "All Items" view you will see 3 items, 2 approved and 1 rejected.

enter image description here

I created a new view named "Test" to show only those items which were approved using this workflow. But when I apply filter as shown in screenshot below, this custom view doesn't display any records.

enter image description here

How do I apply filter so only those items are showed which were approved in workflow?

  • Frank, are you sure you are looking at the correct view? Did you applied the filter on All Items view, or you created a new view? By default All Items view is selected, so if you created a new view, you should choose the view shown in horizontal list beside Find an item box! Sep 11, 2013 at 10:11
  • Yes I made a copy of All Items, named it Test and then applied filter on it. Sep 11, 2013 at 10:19
  • So you sure you are looking at "Test" view rather than "All Items" view! Sep 11, 2013 at 11:18
  • Yes I am looking at "Test" view. Sep 11, 2013 at 11:31

2 Answers 2


If you want to filter it based on workflow status This list might be useful when you creates a view based on workflow status. If you are creating a view for a list filtered by the workflow status, you would need use the number rather than the words (e.g. 2 instead of In Progress, 4 instead of Cancelled etc)

Status Value

Not Started 0

Failed on Start 1

In Progress 2

Error Occurred 3

Canceled 4

Completed 5

Failed on Start (retrying) 6

Error Occurred (retrying) 7

Canceled 15

Approved 16

Rejected 17


I had this exact issue and never found an answer, but in continuing to just "try stuff out," I stumbled across a solution.

Go to "Edit View" and scroll down to the "Folders" link (or if you're creating the view for the first time, be sure to scroll down after setting your parameters)

Click the plus sign next to Folders

Click the radio button next to "Show all items without folders"

When I did that, the correct documents showed up in the custom view. Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.