0

We have an existing info path form with code behind in server A.Now the solution is deployed in the my Development server.This solution consists of info-path form, code behind and code to create custom content types for the document library.

So i published the info-path form in the form library.Now when i open the form and try to submit the form the values don't get saved in the document library. but when i open the form in the edit mode, i see all the values that I entered. I checked the data connection and everything is fine.

One thing i see a difference when i go to server A and browse to the form libraries and go to 'list settings' under 'columns', I see 'Used in' section has two comma separated entries

Column       Used In
Column1     <document library's content type>,<Infopath content types>

where as in my dev box I see the same column has multiple entries

Column       Type                           Used In

column1       single line text        <document library's content type>
column1      single line text         <Infopath's content type>

Any suggestions?

1

I've noticed that sometimes when publishing a form it forgets the column associations and will create a new column with the same display name but a different internal name. I've made it a habit to check the property promotion settings when publishing a form to make sure it is still using the proper columns in the library.

1

On box "A", both content types are using the same site column.

On dev, each content type is using its own "column1".

Try editing the view of the document library on dev. You'll find two "column1"s on the second set up. If you add both to the view, you'll see that your data is being saved into one (the one attached to your Infopath content type) and not the other (the one defined in the library \ list item's content type).

Check the internal name of both columns. The display name is the same, the internal name will be different, and each "column1" field will have different GUIDs defining them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.